PDA

View Full Version : Logitech MouseMan Wheel lag


acx
6th Feb 2001, 10:03 PM
I have a Logitech MouseMan Wheel PS/2 and it lags in UT. I've tried everything in the settings from slecting and unselecting DirectInput and Mouse Smoothing as well as mouse sensitivity, but whatever I do, it just the mouse pointer lags. I am using mouseware 9.24 build 80 on windows 2000 with 256MB PC133 SDRAM and P3 866 and GeForce2 GTS. Does anyone else have this problem or know of a fix for this?

Taker
7th Feb 2001, 11:35 AM
I have a logitrech Usb mouse and was having problems with mouse lag only when I loaded the drivers that came with my mouse.I am running ME,So I don't know if that's the problem your having.I uninstalled the logitech drivers and went with the drivers in ME and have not had a problem since.
:D

acx
7th Feb 2001, 12:59 PM
Thanks for the info. I tried uninstalling MouseWare and Win2k detected my mouse as a Microsoft PS/2 mouse. But I am still getting the same mouse lag in UT.

Taker
7th Feb 2001, 01:56 PM
First,If you have a ps2 mouse attach it and disconnect your Logitech and try the game.If you have no problem with the ps2 try this:Go to your device manager and open the System Folder and open the Mouse folder.Remove everything there.When asked to do a restart click no.Go to Add and Remove Prgrams and remove any Logitech/Mouse drivers that may be there.Shutdown your system and remove the PS2 and attach your Logitech.Let windows install the driver for you.It should say:Hid - Complaint mouse and the name of your mouse +USB if it's a USB mouse.If not Double click on it and change the drivers.Load just the drivers from the install disk.Not the Mouseware.
Only other suggestions I have are the links below.
Hope it helps.
:D


EpicGames Faq (http://unreal.epicgames.com/)

Unreal Tournament Faq (http://www.unrealtournament.com/pc/faq.html)

Ina-Support (http://www.ina-support.com/faq/ut_pc.asp)

acx
7th Feb 2001, 06:30 PM
Thanks for the suggestions taker. I switched to OpenGL and my mouse stopped lagging. So I am thinking that something is wrong with the D3D drivers for my GeForce2 in Unreal Tournament. The mouse seems to work fine in other D3D applications such as Diablo 2 and Half Life though. Oh well, I guess I shall be using OpenGL in Unreal from now on.

Old Fart
8th Feb 2001, 01:17 AM
Anybody have any luck programming the Mouseman's thumb button? I've been told there's a trick to it, but it doesn't seem to work for me. I can't get UT to recognize it, period. :B

acx
8th Feb 2001, 02:24 AM
What typw of Logitech mouse are you using? For me, I have MouseWare 9.24 installed with MouseMan Wheel PS/2. If you open up MouseWare and go to Buttons and then select the 4th button, or whichever button you want to be the middle button, and scroll down the list to Middle Button. Click Apply and Ok. Then go to UT and try to assign that Button to some command. By default I think MouseWare sets the thumb button to Double Click so it will show up as left clickwhen you try to bind it.

Old Fart
8th Feb 2001, 10:42 AM
Thanks for the reply, Acx.

It's an optical Mouseman, and someone's told me that it's just a matter of assigning the thumb button a certain keystroke, then binding that keystroke, but UT doesn't seem to see even that for me. :/

I was hopeful that someone might know of some obscure description that might allow me to hand-bind it (i.e. joy42), but so far I've had zip for luck. Should I bitch at (actually meaning politely seek tech support from) Logitech, ya think? :B

Originally posted by acx
What typw of Logitech mouse are you using? For me, I have MouseWare 9.24 installed with MouseMan Wheel PS/2. If you open up MouseWare and go to Buttons and then select the 4th button, or whichever button you want to be the middle button, and scroll down the list to Middle Button. Click Apply and Ok. Then go to UT and try to assign that Button to some command. By default I think MouseWare sets the thumb button to Double Click so it will show up as left clickwhen you try to bind it.

-Lost-
8th Feb 2001, 12:26 PM
i've got a mouseman wheel usb and i just set the thumb button to be middle mouse button in the windows setup and it worked fine. since upgrading to win2000 though, i can only get the thumb or the wheel to work, not both at once. i usually don't use the wheel in games though, so it's not too much of a problem.

acx
8th Feb 2001, 04:05 PM
I'm not sure if this will help but you can bring up the advanced key bindings in UT by going to the system console from the tools menu and typing PREFERENCES. There should be an entry for MiddleMouse under Advanced->Raw Key Bindings then you can type the command you want to bind it to in the space next to te Middle Mouse. I'm not exactly sure of all the commands you can use but you can figure something out by looking at the other keys or binding the command to another keyboard key and copying and pasting. By the way, this is also available at unreal.epicgames.com link to console commands and way at the bottom. Now all you have to do is bind the thumb button to the middle mouse function that should be available in MouseWare. Check to make sure that you are using the correct driver for the mouse. Sometimes, Win2k detects the mouse as Logitech-compatible mouse for me and I have to manually change it to MouseMan Wheel PS/2.