PDA

View Full Version : Critical Error -- Assertion Failed


TenthFret
27th Dec 2000, 12:59 PM
I have run into a problem that I can't seem to fix, and was hoping that someone might have some sage advice.

I recently decided to upgrade my system, and purchased 128M of SDRAM. I installed it with ease, and fow two days was enjoying life. On the third day, I opened up UT and got this error (or one very similar to it)


/****/
Critical Error

Assertion failed: InPos<=Size [File:..\..\Core\Inc\FFileManagerWindows.h] [Line: 57]

History: FArchive FileReader::Seek <- ULinkerLoad::Seek <- TLazyArray<< <- FMipmap<<
<- SerializeMips <- UTexture::Serialize <- LoadObject <- (Texture city.Alley
14==14/5839832 3597258 174987) <- ULinkerLoad::Preload <- PreLoad Objects <-
UObject::EndLoad <- UObject::StaticLoadObject <- (Engine.Level None.MyLevel
CityIntro.unr) <- LoadLevel <- UGameEngine::LoadMap <- LocalMapURL <-
UGameRngine::Browse <- UGameEngine::Init <- InitEngine
/****/


After playing around with some settings, I decided to un-install/re-install UT . . . to no avail. I pulled out the new memory upgrade, and viola -- no problems.

At first I thought that the memory might have been defective, but yesterday I got another 128M of RAM to test on my machine, and the same issues appeared.

I changed the load-up so that cityintro didn't get accessed, and was able to get inside the main screen -- change all my preferences and player set-up, etc. and everything looks great -- but as soon as I started loading a map -- CRASH.

I re-installed UT, patched, bonus packed, fiddled around -- and out of the blue, everything seemed fine. I played several games with my 256M of RAM and was loving life.

But then I shut down, put the cover back on the computer, re-booted and everything is crap again.

I swapped out my new chips with the original 64M. . . and everything's fine.

My computer seems to run fine with the new RAM, no other apps seem to give me problems, other than UT. I played around with some memory settings and actually got UT to give me some different errors -- like "Ran out of virtual memory. Free up some space on your primary hard drive" -- which is kind of funny since I have about 8 Gigs of free space.


Specs:
SuperMicro 370SWM Motherboard
Pentium III -- 550
Windows 98SE
Vodoo 3 (drawing a blank on exact 1000/2000/3000/etc.)


Any advice would be appreciated

Taker
27th Dec 2000, 01:41 PM
"During launch or while the game is playing, an error message comes up that mentions a 'History Error', 'Assertion Failed', 'General Protection Fault', 'Fatal Exception' or 'Invalid Page Fault in UNREALTOURNAMENT.exe'."
These errors can be the result of a wide variety of problems including low system resources, conflicts between the game and other applications, and hardware problems. Here's some steps you can try:


Shut down all other applications on your computer before playing.
Install DirectX from the game CD.
Update your video and sound card drivers with the latest versions available from the manufacturer.

The error may also be the result of one or more of the video or sound options within the game that don't work well with the hardware in your computer. To test for this, start the game in Safe Mode from the Unreal Tournament folder on your Start Menu. If the game now works, then you may only need to experiment with the options menu to find the feature that's causing the problem.
This information provided from this link:
http://www.ina-support.com/faq/ut_pc.asp :D

TenthFret
27th Dec 2000, 01:47 PM
Yeah, I came across that link too.


No other apps running in the backround
Completed a re-install of DirectX
Have the latest drivers for sound and video
Tried "Safe Mode" too


What's strange is that after swapping the RAM there's no error

Taker
27th Dec 2000, 02:04 PM
Try moving your ram to a different slot if you can.I know that on my mother board if I have slots 1 and 3 wtih 128 ram in each,leaving 2 empty,I have no problems.If I try to put the ram in 1 & 2,Some of my programs won't run.It may sound wierd,but that's how it is.

TenthFret
27th Dec 2000, 02:38 PM
My motherboard has two slots. I have tried as many combinations of chips and slots that I could think of.

Anytime there's at least one of my two 128M chips plugged in, UT gives the error above (or similar) -- but is just fine when there's JUST the 64M.

Prophetus
28th Dec 2000, 03:14 AM
In UT, Advanced preferences, increase your cache meg size between 32 to 64 megs. I really want to know if you are allowing windows to manage your virtual memory. If so, then you need to reconfigure it to a customized setting.

Ensure your new (and old) ram is installed. Goto the Virtual Memory settings and change the maximum and minium to 0 megs (do not do this unless you have at least 128 megs of ram). Restart, and defrag. Soon as defrag is completed, go back to the virtual memory section and change the max and min to 400. Restart.

Also, under file system, change it from desktop to server.

UT is very sensitive and doesn't like windows very much. It appears, from your error log:

Assertion failed: InPos<=Size [File:..\..\Core\Inc\FFileManagerWindows.h] [Line: 57]

History: FArchive FileReader::Seek <- ULinkerLoad::Seek <- TLazyArray<< <- FMipmap<<

Windows and UT are fighting each other on where and what memory to use (virtual or ram). So, try changing those settings. Can't guarantee it will work, but it should get you on the right track.

TenthFret
29th Dec 2000, 10:45 AM
The computer woes continue. . .

I tried changing the cache meg size in Advanced Prefences to several different settings, with no luck.

I changed the virtual memory settings to 0 -- defragged -- changed them 400.

Uninstalled UT.

Re-installed from the hard drive (bonus packed, patched 428, cracked 428, patched 436, etc.) and when I was all finished and loaded up UT, I got the same type of errors -- alternating between "Assertion Failed" and "Ran out of virtual memory"

So I decided to give up for the time being and get some playing in, so I swapped the RAM and put the original 64 back in (which usually returns me to status quo) and some weird things began to happen.

1) I can no longer Alt-Tab out of UT -- the whole thing crashes.
2) Sometimes, other players seem to float through the floors, not walk on top of them as physics suggest we should, but they seem to have no legs. . .
3) Sometimes, other players become invisible. This makes it somewhat difficult to frag them (despite my massive elite skills :)
4) Sometimes, after someone is killed, a figure of the person appears in the spot of the death. It looks just like a regular opponent, but if I kill it it just explodes. It really shocked me when I came across an image of my character where I had just been killed. Kinda weird to frag yourself. . .
5) There doesn't appear to be any animation for other players movements, they are skating around.

{this is your computer. . . this is your computer on drugs. . . }


So, I'm still looking for advice on how to correctly implement my 256M of RAM sitting in my desk drawer
AND
now I'm looking for advice on how to correct the above problems with my measly 64M of RAM if I can't include the memory upgrades.


grrrrrr

Nevar
29th Dec 2000, 01:40 PM
Did you install the textures on disk two for some reason?
You are using glide right? Ahhh cracked 428? Patching an altered UT.exe? ie nocd patched? Not good! Just go straight to 436..or try the below..Did you run a memory testing program on your 128 sticks?

Try this from epic..
We are also seeing reports of several different problems that appear to be due to problems reading specific files off the game CD.
For example:

Critical: appError called:
Critical: Assertion failed: InPos>=0

You might try the following reinstall procedure, simple as it seems it has helped a lot of people with weird errors.

Corrupted files are sometimes installed without any error messages with some CD-ROM drives; data is copied to your HD with read-errors, but for some reason the CD drive doesn't warn the installer and everything appears to have installed OK.

Copy everything from the CD to the hard drive, (running scandisk first to be absolutely sure there's nothing wrong with the hard drive) then install from the hard drive to the final destination folder. Also, please make sure you install into a clean (new) folder, not on top of any existing UT or UT-demo content.

TenthFret
29th Dec 2000, 02:15 PM
I did install the textures from CD #2 -- (was trying anything and everything at one point or another)

I've come across references to the CD #2 textures causing some of the "minor" problems in my most recent post -- i.e. skating, etc.

Yup on the Glide.

So, I'm planning on un-installing / re-installing -- without the #2 CD.

After thinking about it, you're right about patching a cracked UT.exe. I didn't have the 436 No-CD patch (just picked it up a few seconds ago). But I originally patched 436 on top of a cracked v428 that I had been running and didn't have any problems for a month. (go figure)

Memory Testing Program. . . ?

Don't have one that I know of, or where to get one.

My computer seems to be running fine other than the UT issues (not that I use it much other than UT)

w/ respect to the advice from Epic

My latest install was from the hard drive and into a NEW folder.

Too bad that work (and holidays) gets in the way of important things -- like more un-installing/re-installing. :)

Thanks for the input, I'll keep at it

Nevar
30th Dec 2000, 12:51 PM
Here is one of many memory testers..
http://www.tweakfiles.com/memory/goldmemory.html

Also with 436 patch you will not need a no cd crack as it and patch 432 do not require the cd to play the game any longer.. I think you are the right track now good luck