PDA

View Full Version : net code problem


irongull
11th Nov 2000, 03:00 AM
Ok, here's the situation:

I've written a mutator for CTF that spawns actors that monitor the state of the flags, and give the flag carrier a special weapon. The actor itself looks like a pickup version of the weapon. The code for the weapon, and the mesh and skins, are all part of the same package as the mutator. The monitor is set to ROLE_SimulatedProxy.

When I play it locally, everything is fine. I can see the weapon at the flag, I get the weapon when I grab the flag, and I can see the beam it fires just fine.

When I play it over the net, however, I can't see the weapon sitting at the flag, and I can't see the weapon when I'm holding it. I also can't see either the beam it fires or the redeemer-like blast it makes. I know that it is running on the server, because I can kill bots with the weapon even though I can't see it or its beam. And the special death messages that I put in don't appear on screen. Most disturbingly, when I or a bot has the weapon selected, the flag being carried dissappears.

When I load up a test level that has the weapon explicitly added into it, everything works just fine in net play. I have a .int file with all of the classes in it, but it seems like the client just doesn't know how to load and display the weapon, or any of the other classes, when the mutator tries to load them. Even though they are obviously being loaded on the server side, the client doesn't see it. They only load when part of a level, which sorta defeats the purpose of a mutator.

So I guess my question is: How can I get clients to load and display the weapon etc...? How do I get the mutator to load things on the client? I've tried checking all the simulated function calls - it should all work. But it doesn't. And I'd really like to get this thing finished and out the door. Its overdue... Any insight you may have would be appreciated.

Aphex
12th Nov 2000, 05:55 AM
Hmm sounds complicated :eek:

Errm have you read the blacksway doc on replication?http://www.planetunreal.com/pipeline/tutorials/replication.html

irongull
12th Nov 2000, 06:01 AM
Turns out that it wasn't a problem with the mod at all - I had misconfigured the server by editing the wrong ini file. Just a bit of stupidity on my part. Solved now, and the mutator is happily released. Thanks for the link, tho.