PDA

View Full Version : linux mouse problems


wiley
27th Nov 1999, 12:20 AM
I had some trouble getting the full game running under linux, but now the only hurdle left is the mouse. The first problem I ran into was running the game from enlightenment. It started fine. I saw the startup screen and then my perfmeters shot up to 100% cpu and everything locked up. This did not make me happy. I then tried to play from X without a window manager. I did an xinit -- :1 -bpp 16 and fired up the game from the xterm. The startup screen showed up and then the screen did this weird split thing and the sound from the intro city scene started up. I had to ctrl-alt-bksp out of that. Ok, at least I had sound now. I then fired up the old trusty twm and tried again. Startup screen, intro with video and sound, and then the menus. Needless to saw I was excited and ready to play. To my great disappointment, the mouse control is terrible. I had to turn the sensitivity way up to even make it semi-usable, and it is still very jerky and hard to control. It kind of feels like the mouse needs to be cleaned and is skipping. I cleaned the mouse with my fingers crossed, but the problem persists. What a let down! The demo played great under linux without all the install headaches. I guess I will just have to grit my teeth and try to adjust to the flakey mouse while waiting for a fix.

Any help will be greatly appreciated!

Thanks,
Wiley