PDA

View Full Version : Unreal monsters/weapons in UT Maps


FenderTX
18th Dec 1999, 03:54 PM
I was trying to insert unreal monsters or unreal weapons into a map i was making for UT. It seems that all of the sounds, models, textures, code is iuncluded for all of the Unreal monsters and Unreal weapons with the copy of UT that installs. The 3d models for the monsters and weapons appear in the map when you insert them but when you go to play the map they are not there. I suppose this is because I'm trying to play the maps deathmatch style in UT. So my question is...Is there anyway I can make a single player map for UT that I could play against unreal monsters in? Or is there anyway I can use any of the Unreal weapons in UT? I saw some command line parameters on the front page of the planet unreal site that would allow you to run unreal maps with unreal monsters in UT and play with UT weapons...anybody know anything about that? If thats possible maybe I could use Unreal weapons or unreal monsters in a map I make for UT.

Recon14
18th Dec 1999, 07:26 PM
Hey maybe(the key word) if you copy the old Unreal .u files into UT the Unreal game styles would come up and you would have the weapons from UT too, but as far as you could get is having to summon the weaps. Not sure, dont have UT yet but I'll tell you as much as I know.

alien8
18th Dec 1999, 07:30 PM
okie, here's a work-around.

To start UT using your single player map, you have to do it at the command line.

c:\UnrealTournament\System\unrealtournament.exe MAPNAME?game=unreali.coopgame

Where MAPNAME is replaced with your map's name.

I think that would work, let us know the message board here.

Good Luck!

http://www.planetunreal.com/images/bullet2.gif
alien8
PlanetUnreal (http://www.planetunreal.com) | ModCentral Unreal (http://www.planetunreal.com/modcentral)

Wanderer
18th Dec 1999, 09:18 PM
Actually if you change the DefaultGameType to an Unreal one it'll play just like Unreal. Up until the point you pick up something from UT and then it gets strange on ya.

FenderTX
18th Dec 1999, 09:48 PM
ok so would I include the question mark..and do I include the .unr extension on the file name?

and wanderer do I need the original Unreal installed on my hard drive for that do work?

keet
18th Dec 1999, 09:57 PM
Thats strange. They worked fine for me and I did nothing special.

One day I was starting to make a ctf map but turned out making it into a neat level with monsters like the titan and some skaarj.

I went to play it but never changed the name(it was listed as ctf-test). Hck i didn't even have a flag base set.

Anyway, all the monsters were there and they all acted properly.

FenderTX
19th Dec 1999, 01:02 AM
thats probably because your default game was set as unreal or you already had unreal on your hardrive i guess...anyway i used the command line parameter and it works great. All of the weapons worked except for the quadshot..whatever that is

alien8
19th Dec 1999, 01:06 AM
The quadshot was one of the weapons that was going to be included in the original Unreal. It wasn't, however, the model was.

As you noticed, it does some funky stuff when you try to pick it up /~unreal/ubb/html/wink.gif

http://www.planetunreal.com/images/bullet2.gif
alien8
PlanetUnreal (http://www.planetunreal.com) | ModCentral Unreal (http://www.planetunreal.com/modcentral)