PDA

View Full Version : UE3 - UDK Put it online?


emckai
15th Aug 2010, 12:07 AM
I"m just wondering how I can put the map I created online.

I know some games out there, such as AVA (Alliance of Valiant Arms) use UE3 and put their maps online.

Is there any way I can do that?
I would like to play a map with my friends without downloading the whole UE3.

brold9999
15th Aug 2010, 07:39 AM
I'm not certain which you are trying to do.

You ask about putting a map online - ie so other people who already have a UE3 based game can download that map and play it. There are lots of sites where you can do this.

But you also mention, playing the map without downloading the entire engine, which implies you don't already have such a game. Are you talking about running a UE3 game in a browser?

emckai
15th Aug 2010, 12:51 PM
Yes, something like that, running the game in a browser.

Because I don't want my friends to be downloading and installing UE3 just to play the map I have created.

brold9999
15th Aug 2010, 01:24 PM
The UDK doesn't provide the ability to run it in a browser. Even when you play [these types of] games in a browser, they still download and run on your local machine. They will have to have the game on their machine one way or another*.

* Excluding roundabout methods such as running multiple instances on your machine and friends connecting via VNC or the like, which would prove me wrong but would not be practical.

emckai
15th Aug 2010, 08:22 PM
Uhh, I think I didn't make myself clear D:

Pretend I created a map with the UE3 Editor.
After I compile it, and turn it into a real map.

How can I play that map with my friends?

Would they need to download the UE3 UDK and the map I have created?

eblade
15th Aug 2010, 10:09 PM
Go to UnrealFrontend, Package Game.

emckai
15th Aug 2010, 11:52 PM
Will I be able to play online with them? o_o

emckai
16th Aug 2010, 03:02 AM
I got everything packaged and all that.

But when I try and get onto the server by using ~ and open [ip address:7777]

I get a Connection Lost:
Package 'UnrealEd' version mismatch [package 00000000000000000000000000000, info 6a4f49324d1a62076e32738bcffed399]

And on the cmd-like window

netcomego: close tcpipconnection_0 [ip address]

brold9999
16th Aug 2010, 06:47 AM
Are you playing the version you packaged or the pre-packaged version?

Not sure if this makes a difference but it's the first thing I would check.

emckai
16th Aug 2010, 11:49 AM
When I try and connect to the server with the package that has everything, the editor, game, frontend. When I use the Game client from that, and type in open [ip address]

It works just fine, it connects and all that. But when I use the packaged client from frontend.

Frontend -> Package Game -> install -> using that client.
I start up the game client, then when I type in open [ip address], it attempts to connect, but then it gives that error from my last post.

brold9999
16th Aug 2010, 12:49 PM
Are you using the packaged *server*, or are you using the the unpackaged UDK as server?

emckai
16th Aug 2010, 01:02 PM
I'm using the UDK as server.
It's the only one with the Unreal Frontend.

emckai
16th Aug 2010, 01:44 PM
I'm trying out different UDK right now.

The already tried out the latest one, the March UDK and right now i'm going to try out the December UDK 2009

emckai
16th Aug 2010, 02:02 PM
Yeah. Same thing happens with all the UDK I just tried out.
There is obviously something wrong with the UnrealEd.u

I tried replacing it with the one in my UDK, but it still doesn't work.

brold9999
17th Aug 2010, 06:06 AM
From the error message you are getting, it sounds most likely that you either have to all be running the UDK, or all be running the packaged game. I don't think you can have some people running UDK and some people running the packaged game.

emckai
17th Aug 2010, 09:17 AM
Oh alright. okay thank you