PDA

View Full Version : UE3 - UT3 Mover problem


trauma
14th Sep 2009, 04:48 PM
I am currently redoing all my lifts with the meshes I want to have in the final version of my level and I have come across a problem that I haven't encounter before and I can;t find any threads about it on this forum.

I am trying to use the Necis elevator 3 mesh as my lift base and it requires me to rotate the mesh so that it looks proper. So I rotate my mesh and trigger the the mesh rotates back to its original position and then goes up.

I have checked numerous level in UT3 to see how they did this and have not found anything in other mover properties that look different than mine, and I know it is fixable cause many lifts are in different directions and go up just fine with out this problem in other levels.

So does anyone know the solution to this problem? any help is much appreciated.

Thanks in advance

Bi()ha2arD
15th Sep 2009, 07:01 AM
to fix this you unfotrunately have to delete your matinee sequence and redo it. (or change the keyframe rotations). i think when you add your mesh as mover (which you did with your placeholder mesh) the matinee somehow uses absolute coordinates and rotation and therefore rotates the mesh to what the old one was.

Bazzwano
18th Sep 2009, 05:27 AM
to fix this you unfotrunately have to delete your matinee sequence and redo it. (or change the keyframe rotations). i think when you add your mesh as mover (which you did with your placeholder mesh) the matinee somehow uses absolute coordinates and rotation and therefore rotates the mesh to what the old one was.

Not true. Well not the best way to go about it anyway.

Just go into your kismet matinee and right click the movement trace and set it to relative (I'm not in the editor but Im sure its relative). This way your kismet will work on the lift where ever it no matter its placement or rotation.

Bi()ha2arD
18th Sep 2009, 08:27 AM
oh, i must have overlooked that feature all the time then :(