PDA

View Full Version : The Ball - Teotl - Released!


Hourences
7th May 2009, 08:11 AM
It took our team 7 months, but we have released the third installment of The Ball!

# At least twice as big as the previous release
# We have redone large parts of the first three levels.
# More than 4 hours of singleplay gameplay
# 100 Percent all new art and content
# Over 16 secret to discover and one very hard to find shortcut.
# Solve puzzles and fight monsters in a mysterious world deep inside a volcano!
# Previous installments have won a tripple first prize in the Make Something Unreal contest and was awarded "Best Singleplay Mod of 2008" by ModDB.


http://www.nijnka.com/hourences/theball/media/gorillafight2.jpghttp://www.nijnka.com/hourences/theball/media/theballteotl15.jpg
http://www.nijnka.com/hourences/theball/media/theballnearrelease1.jpghttp://www.nijnka.com/hourences/theball/media/theballnearrelease4.jpg


Trailer available here - http://www.youtube.com/watch?v=QWFUYRhjb3Q


____________________________________________


DOWNLOAD
http://www.nijnka.com/hourences/theball/images/fileplanet.jpg (http://www.fileplanet.com/193016/190000/fileinfo/Unreal-Tournament-3---The-Ball:-Teotl)

http://download.beyondunreal.com/fileworks.php/mods/ut3/TheBall-Teotl.exe
http://files.filefront.com/TheBall+Teotlexe/;13721993;/fileinfo.html
http://www.megaupload.com/?d=JAENBEN3 (TEMP)
http://www.atomicgamer.com/file.php?id=78052


____________________________________________

Creative Director - Sjoerd "Hourences" De Jong
Programming - James "SolidSnake" Tan - Russ "Vaninadisc" McMackin - Markus Arvidsson
Level Design - Sjoerd "Hourences" De Jong - Thomas "Setheran" Browett - Kevin "Sklare" Cytatzky
Additional Level Design - Anton "Rendermonkey" Botvalde - Russ "Vaninadisc" McMackin - Dan "Daze" Banefelt
Level Scripting - Anton "Rendermonkey" Botvalde - Thomas "Setheran" Browett
Environment Art - Sjoerd "Hourences" De Jong
Character Art - Bart "Pestibug" Wiltenburg - Elusive - Markus "Tores" Palviainen
Additional Character Art - Manti
Animation - Hongman "Whackzero" Leung
Additional Animation - Markus "Tores" Palviainen - Charles "EvilEngine" Jones
Original Music and Audio - Theodore Wohng
Additional Music and Audio - Epic Games
Voice Acting, Video, Additional Sound Design - Henrik "Bersy" Ryosa
Additional Help - Hal:Forums - Hazel;Textures - Mr.Prophet:Story - Utz:Animations - SBR:Palm Trees - Polycron:Loading Screen - Winegums:Website - DGUnreal:Programming - Zynthetic:Intro Voice Acting - Psychotropic Circle:Music Samples - Cgtextures.com:Textures - And the unknown makers of our fonts

civanT
7th May 2009, 09:53 AM
At last. Thank you.

Drummer.unr
7th May 2009, 05:18 PM
Hi, great job on the mod, it's really got atmosphere, polish, and fun!

I've been playing it for a few hours now, and I seem to be stuck for some reason towards the end (i think it's the end) :(

http://img152.imageshack.us/img152/6428/theballstuck.th.jpg (http://img152.imageshack.us/my.php?image=theballstuck.jpg)

The platform is all the way down, i can walk over it, but the ball collides with an invisible wall and won't roll onto the plate.

Now, either i'm missing something obvious or there's a bug of some sorts...

I don't want to have to start over, and i really want to fight that big gorilla from the screenshot :D

Hourences
7th May 2009, 05:40 PM
Should work, sure it is not just stuck on the little ledge? The button sticks over the floor a tiny bit.

I will test this again right now to see if it works.

Edit: Worked here. There is indeed an invis collision over here that prevents people from getting the ball on too early - however at the stage youre at, it should be gone. And it has worked for us every time. Either it is the little edge or it did really mess up as a one time event.

Drummer.unr
7th May 2009, 05:54 PM
The collision is still there, cause i tried to jump the ball "up and over" and it hit the invisible wall about two ball sizes above the ground.

It seems the pillar went down but the collision did not.

Maybe i just got unlucky :/

Hourences
7th May 2009, 06:06 PM
Hm, you should try again by reloading the level and see if it does work that time.

If you want to quickly skip the whole thing, you must go into ghost mode, fly straight out of the caverns at the start to the entrance of the city, and go back to walking there. Make sure the cutscene that overlooks the city starts as it is a checkpoint. After cutscene, kill yourself, and you will respawn there with the ball, thereby bypassing everything inside easily.
You can also use fly mode to quickly unlock 3 out of the 5 puzzles in the city so you're back down below at the pillar in no time.

Drummer.unr
7th May 2009, 06:35 PM
Ok, well it worked this time, guess i got unlucky or did something in the wrong order...
thanks

Sanyika
8th May 2009, 04:58 AM
Hello guys! I'm a long time fan of your mod, but this is my first post on your forums, because, well, i have a problem :D

I tried it with manual and auto install and always get the same error. The game launches, i see the splash screen, the Toltec logo video, then silence and blank screen. Any idea what should I do? I had no problem with the previous Ball mods or any UT3 mod. Even the new Haunted runs smoothly (I'm just saying because it has own shortcut too, so that's not the problem).

TW216
8th May 2009, 06:58 AM
Make sure that you have 2.0 Patch or later ;)

Sanyika
8th May 2009, 07:19 AM
Yep i have 2.1 and the Titan Pack installed.

lango
8th May 2009, 08:02 AM
Try to wait a bit longer. The first startup can take a long time for some reason.

Hourences
8th May 2009, 08:13 AM
Make sure you got the previous versions of the mod uninstalled.

The first run can take a while, tho not more than a minute or two max. There is a Launch file in the log folder in my documents, it is the log file of what happens. You can open it in notepad and have a look, or email it to me@hourences.com

Sanyika
8th May 2009, 08:40 AM
Believe me, I waited for at least 10 mins :)

Thanks for helping me, here's my log file:
http://foundation.atw.hu/Upload/LaunchLog.txt

Hourences
8th May 2009, 11:36 AM
The log just cuts off at the end. Thats the case with your local copy too or did it not upload properly? If it just cuts off, that means the error is not even recorded and it may be more serious or something that occured outside of UT.

It did just tried to resolve a webaddress and contact it. Could it be something as utterly simple as perhaps a firewall popping up a message in the background "allow connection"? Or something related.

Sanyika
8th May 2009, 11:46 AM
I checked it, it did upload it perfectly, so that's not the case.
Firewall? I don't know, it does not respond to alt+tab or ctrl+alt+del.
Well i do have Kaspersky installed. Let me check when I close it.

No, it's the same. Tho i noticed that the log was shorter this time, because I reboot Windows after 3-4 min, not after 10 min like last time. Let me try it with 15-20 min, so the log would be longer :rolleyes:

Hourences
8th May 2009, 12:08 PM
I just had someone else who experienced roughly the same, tho his just errored and didn't hang.

Lets try other things:

C:\Documents and Settings\Hourences\My Documents\My Games\Unreal Tournament 3\TheBall\Shaders

Delete the file in there. This will cause it load even slower but it will rebuild the cache by itself. If you run the game with -log command line, and then run the game in windowed mode, you can see what it is doing in the background by looking at the log, and you can see if it still does something (aka worth waiting), or just totally hangs.

You can make the game run in windowed mode by going to

C:\Documents and Settings\Hourences\My Documents\My Games\Unreal Tournament 3\UTGame\Config

UTEngine.ini

In notepad search Fullscreen=True and change it to False. Optionally change ResX and ResY a few lines below to make the window not cover your whole screen.

Hourences
8th May 2009, 12:11 PM
Also if that does not work we should try to bypass the menu and go directly to the game.

In that same UTEngine.ini, at the very top there is:

Map=TB-FrontEnd.ut3
LocalMap=TB-FrontEnd.ut3

Change both to TB-Part1-Pehua.ut3

Accuphose
8th May 2009, 02:08 PM
1) I have same Problem with panel into the screen (from Drummer), one button put down less and i play this level second time, all work fine
2) What its the point collect secret? I played this time Teotl I a II and i found 1 item (3 of 3)
3) What is advantage The Ball multiplayer game?
4) Interactive ambience - If i go to water, block me invisible wall...this is not good feel

But the mod is fantastic work, thanks you. Maybe is time to talk of making story. Yes all its better than stupid story..If you have interest, i cant help you...;)

EDIT: Its good idea making The Ball wallpaper? :-P

Sanyika
9th May 2009, 02:59 AM
The running-in-window thingy does not work, I see that it's loading, than stop, than black screen again. The last thing I saw in the log in the background was "Error sending test packet"
Now trying to bypass the menu and go directly to the game...
Well, that's not working either :(
This time, it's just crashed not froze. Log in the back: http://users.atw.hu/foundation/Upload/TheBallError.jpg

Hourences
9th May 2009, 06:47 AM
And it is in the right dir?

I really have no idea why it works for everyone but you.

What language is your UT itself in perhaps? I know that with the first release we had issues with a russian version or something.

Sanyika
9th May 2009, 06:53 AM
Yes of course it is in the right dir :) C:\Users\Szabó Sándor\Documents\My Games\Unreal Tournament 3\
That's where the UTGame, Binaries, and HauntedGame folders are.

Well, my game is localized in hungarian language, but I change it everytime I reinstall UT3 in the UTEngine.ini ("Language=INT").
So yes, it's english.

Well my PC isn't the flagship in the fleet, maybe it has to do something with it:
Acer Extensa 5620G
Intel Core Duo Processor T5550 (1,83 GHz, 667 FSB, 2 MB L2 cache)
1 GB Ati Mobility Radeon HD 2400 XT HyperMermory
2 GB DDR2

Hourences
9th May 2009, 07:25 AM
You also got a TheBall folder there right. Your log seems to imply so.
In that log there is everything there should be right? The whole folder is 358 MB large, give or take a megabyte.

You tried deleting that shader file?

I really don't know. We did the same things as the haunted did as far as I know. Nothing weird or special. Vista 32 bit or 64?

Sanyika
9th May 2009, 07:32 AM
I have Wista 32 bit. Yes it's exactly 358 MB.
I tried deleting the shader file. It took the game to load a bit longer, but BEFORE the Toltec video.

Sjosz
11th May 2009, 02:20 PM
Initial install did not go very well. Probably because I had an older version of the ball still installed, it made everything an ambiguous package, and crashes start-up at the splash screen. I've tried removing everything related to the ball in both the game's install directory and the my games directory, re-installed it, but it persists, referencing to ghost folders that don't exist.

Maybe consider an automatic uninstaller of older versions next time around. It looks like I'll have to reinstall UT3 from scratch here at work to be able to get this mod running. :hmm:

Hourences
11th May 2009, 02:34 PM
Everyone got it to run without reinstalling the game. You are missing a file somewhere. Do a windows search?

You shouldn't have stuff in the install dir. If you had, don't blame us :)

It is suppose to be as simple as removing 1 single directory and done.

Sjosz
11th May 2009, 03:19 PM
Meh. Turns out I had the very first release in my 'my documents' folder substructure, even though the unreal warnings said they were in my install directory.

Managed to get to Oztoc 2 in my lunchtime. Initial thoughts:
- Decent re-work of the old levels.
- I like having the secrets to look for, though I suck at finding them.
- Not being able to skip through cutscenes with a button is terrible, detracts from the pace I want to have.
- The narrative VO sounds awkward, like the person was forcing himself to speak neutral English which didn't entirely work out.
- Combat works, somewhat, though almost the tiniest bit of momentum will kill the zombies.
- Slideshow loading screen.
- Quite like the music/ambient stuff.
- Improved the cube physics, thankfully.
- Killing monkeys is fun.
- Am hoping the additional levels give me a different colour palette or at least more variation.
- Dodging the lava-rock thing into water is still lame.
- Nice main menu.

Those just sort of came to mind while writing this. Am hoping for more puzzles that actually require puzzling though, so far the puzzles have largely been press arbitrary button to open arbitrary plot progression door. More feedback after tomorrow's lunchtime session. Decent improvement on the last version so far.

Bersy
11th May 2009, 07:50 PM
I don't need to force myself to speak neutral English, since it is pretty neutral already. So far you and one other person are the only ones I've seen complain about it out of all the sites where people are discussing it. Both on BU. Go figure.

Sjosz
11th May 2009, 08:45 PM
I don't need to force myself to speak neutral English, since it is pretty neutral already. So far you and one other person are the only ones I've seen complain about it out of all the sites where people are discussing it. Both on BU. Go figure.

Yeah, not really. I'm not saying you are forcing yourself, it just sounds that way. Your pronunciation is definitely not neutral English, you have a light non-native accent. The VO simply doesn't sound natural. (as in, it sounds like it was recorded for a mod, not like genuine narration).
Of course, I have no idea what to suggest to improve that, and you may very well think that it's fine. I'm not complaining about your voice, I'm simply pointing out that the narration sounds unnatural/canned.

Bersy
12th May 2009, 12:18 PM
I understand what you are trying to say. All I can say is the way it was read was intentional and IRL my accent is very neutral, I am a native North American english speaker.

DWolvin
12th May 2009, 03:39 PM
Actually, I disagree, I thought the voiceover was nicely done, but then again, opinions are like /bad thing here/...

On the other hand, any hope for some hints? I'm just after the square columns and the elevator / magnet puzzle, the Ball is under the floor, and the teleporting maze has me stumped. I can get to within a bit over 400 units to the Ball, and then get teleported back to room #2 (next to the only symbol equipped center column)...

All in all, I have really enjoyed the mod, so much so that I didn't mind the jumping puzzles over the lava. I really hate those, so it's really a compliment, honestly!

Hourences
12th May 2009, 04:22 PM
Follow the river. See through the grating where it goes and follow that)

Full walkthrough upcoming later.

DWolvin
12th May 2009, 05:30 PM
Ah~ I feel silly. Thank you for a great afternoon, I did the first two ep's yesterday. The boss startled and scared me- Love it! One question... The fur texture seemed shimmery, on a radeon 9850, maxed ingame settings. Have you seen this? I'm off to check the UT3 board to see if that's a known issue...

Alhanalem
15th May 2009, 12:11 PM
I don't need to force myself to speak neutral English, since it is pretty neutral already. So far you and one other person are the only ones I've seen complain about it out of all the sites where people are discussing it. Both on BU. Go figure.
It's not bad or anything, but it did sound a little... odd, to me. Just the intro VO on the very first level. Though I think it was more the actual dialogue itself more than your voice.

Bersy
15th May 2009, 02:10 PM
Yes, the first part is a bit tricky. I am sure some adjustments will be made for the next release.

[NBK]Rattman
17th May 2009, 01:09 AM
I just finished the mod and I'm really impressed at the level of polish that you guys have in this thing....

I can see the final version going retail for sure!

Sanyika
13th Jun 2009, 10:39 AM
Had to reinstall windows yesterday, so I gave The Ball another try...and it's working now :D I have absolutely no idea what was my problem, but no matter, I'm just happy it's fine now :)

popsUlfr
15th Jun 2009, 05:55 PM
I just had to register to express my thoughts on your project:

This is Sick! :D It has a level of polish and professionalism to it that you usually don't find in Mod content. The Game got me hooked from start to finish, I was addicted to the ball! Yes, coming to the ball... what a lovely gameplay element you introduced here. I don't know if I'm the only one who felt like a close relationship growing between "it" and the player. "Portal"'s Companion Cube would come into mind. I found myself talking to it "Where are you?", "Look what you've done to those poor mummies!", "Are you tired?", "I know you like me, and I feel the same. But a safety distance would be advised or I will end up sticking to you like a pancake!", "What are you doing down there?!"... (no need to phone the doc, i'm already taken good care of...). Just to say how powerful such a device can be both on the player and on carrying on the story. In this hostile world it's the only companion you can actually trust, a valuable friend more so than having 20 guns in your inventory.
I could continue iterating on it but i will just bore you to death(or scare) with my ball fetish :P

The Puzzle elements were straight forward, I managed to solve them with relative ease. Therefore I wouldn't mind some tougher ones, those who'd give me headaches :) . The mixture of puzzle and combat elements are revolving around the ball, the balance between them was done well to be honest and I didn't mind the occasional Mummy making me run for my life while I couldn't access the companio... ehh Ball XP

Ok, telling you that all's well wouldn't exactly be helpful for developers though. Would it?
About Save-System: Checkpoint based is fine. But the possibility to load a checkpoint instead of replaying the whole Level would be neat. But you said that UT3 doesn't really support a feature like this, so I don't count on it being fixed (I played the mod in one sitting though).
Puzzles... I can just see how much work and thought went into them... So I would just suggest keeping it up, they should always get a special treatment. Trickier ones involving the player to go back and forth in a Level (sort of puzzle boss) would be welcomed.
Maybe expanding the game menus, like having your own Pause Menu (nitpicking at best!)

Not much I disliked. The pace is excellent, smooth gameplay nice use of physics.

Good job, keep it up and I wish you good look for your future endeavours ;)

Hourences
16th Jun 2009, 04:54 PM
Thanks a lot for your feedback and we are very happy to hear you enjoyed it so much !:)

popsUlfr
18th Jun 2009, 05:00 AM
No problem. I didn't post about 2 minor issues I had encountered (I will try to get pics on my next playthrough): 3 cutscenes resulted in some corrupted lines all over the screen, and there was one part where you could get stuck. The part where you had to guide the ball through magma while the player being a level higher. With the ball you must hit a button to open a sliding door which lets the player go on but makes the ball unable to pass. At first it was all fine but in the end I somehow managed to lock myself out lol. No way to reach any button nor the ball, because it actually rolled behind one of those doors before it begun sliding. Sorry for the precaire explanation, but the thing is I had to suicide to actually reach the ball again.

EDIT:

*About the screen corruption, here's a shot of it happening in the Level "Oztoc II":
Just before the Cutscene:

http://i44.tinypic.com/9hjlf7_th.jpg (http://i44.tinypic.com/9hjlf7.jpg)http://i41.tinypic.com/2m663va_th.jpg (http://i41.tinypic.com/2m663va.jpg)

During the Cutscene:

http://i40.tinypic.com/2w4d5dz_th.jpg (http://i40.tinypic.com/2w4d5dz.jpg)

Not sure what could be the problem, I noticed it happens when the player is near a "fluid source" (water, magma)...

*About the part where I said one could get stuck (also encountered in "Oztoc II"):

http://i40.tinypic.com/30m36h2_th.jpg (http://i40.tinypic.com/30m36h2.jpg)

I think you can see the problem (I used "ghost" mode to get a better overview shot), the Ball is basically out of reach. The only button working at this point is the "ball button" beneath the blue one. But without the ball it's somewhat a hopeless situation.
Beginning from the "Entrance" when you activate the ball button of the 3rd compartment and don't pay attention to it because you're heading for the blue button in the 4th compartment, it is possible for it to roll back into the second compartment. Once you activate the blue button of the 4th compartment, the door of the 2nd compartment succesfully looks out the ball and as a consequnce the player itself. This may be done on purpose though, you just have to make sure it actually stays in the 3rd compartment to be able to continue.