PDA

View Full Version : UT2004 and Windows 7


Thanatosaurus
21st Feb 2009, 10:59 PM
Has anyone tried running UT2004 under one of the betas of Windows 7? I'm thinking of changing over to 7 when it's released, but won't do so unless it can run 2004. Thanks.

shoptroll
21st Feb 2009, 11:09 PM
Haven't had any trouble here on Build 7000 (the public one) in 64-bit mode.

vybz
22nd Feb 2009, 01:06 AM
I am runs perfectly fine

GreatEmerald
22nd Feb 2009, 07:14 AM
It runs perfectly, yes. However, the editor will not. I'm not sure, but you might just need to install DirectX 9 to make it run correctly, though.

Thanatosaurus
22nd Feb 2009, 09:05 AM
I thought UT2004 installed DirectX when it's installed. Will DirectX 9c (the last version of 9 released) run under Win 7?

shoptroll
22nd Feb 2009, 11:07 AM
Yes.

GreatEmerald
22nd Feb 2009, 02:27 PM
Yeap, it does. However, the DirectX9 provided with UT2004 isn't the latest version, there were numerous updates to 9c. So you will still need this:
http://www.microsoft.com/downloads/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&DisplayLang=en

Alternatively, if you want to use download managers:
http://www.microsoft.com/downloads/details.aspx?FamilyID=886acb56-c91a-4a8e-8bb8-9f20f1244a8e&DisplayLang=en

cUnNiNg_StUnTs
23rd Feb 2009, 07:01 AM
AFIK Whenever a newer version of DirectX setup runs it just goes through the motions and does not replace any newer files. It's not like .NET where you can have all 3 versions running on one machine. 10 supersedes them all.

I am running Windows 7 32 bit and UT2004 installs and runs great.

Dark Pulse
23rd Feb 2009, 03:02 PM
Yeap, it does. However, you don't need only DX9, you also need DX8 and DX7, because basically UT2004 is based on DX8. So you will still need this:
http://www.microsoft.com/downloads/details.aspx?FamilyID=2da43d38-db71-4c1b-bc6a-9b6652cd92a3&DisplayLang=en

Alternatively, if you want to use download managers:
http://www.microsoft.com/downloads/details.aspx?FamilyID=886acb56-c91a-4a8e-8bb8-9f20f1244a8e&DisplayLang=enGreatEmerald, DX9 contains all implementations of DX prior to it. He won't need to get DX7 or DX8 if he downloads DX9.

GreatEmerald
23rd Feb 2009, 03:33 PM
I know. That's why I linked to DX9 :p

Dark Pulse
23rd Feb 2009, 05:32 PM
Yes, but the way your post sounded, it sounded like he'd need to get 7, 8, and 9 in that order. :p

GreatEmerald
24th Feb 2009, 09:34 AM
Ah, OK, fixed :)