PDA

View Full Version : Logitech Precision Gaming Headset - Right channel problem


Zur
27th Dec 2008, 02:50 PM
Hi,

If anyone else out there has one of these headsets, I got one a while ago and have been having a problem with the right channel suddenly going on the blink every now and then. The sound does come back when pull the cable towards me instead of letting it drop down.

I'm wondering if there's anything I can do to fix this. I'm willing to bet the cable has gotten twisted like many of my headsets in the past. Perhaps the problem is in the volume control. If so, is there any way to solder the tiny cables inside ? They seem to have something on them that stops solder bonding with them.

shoptroll
14th Jan 2009, 12:54 PM
Is this the same headset that came with the UT2004 Collector's Edition (whichever version shipped on a DVD)? Mine recently started to go on the left channel with a similar problem, not to mention the fuzz padding has deteriorated and is now just flaking off.

Sir_Brizz
14th Jan 2009, 07:27 PM
yeah, if it's that one same problems for me. The microphone cover thing is gone, eaten through. The ear pads are eaten through. The volume control is weakening contact so I get lots of static and the channels go in and out.

I bought an Altec Lansing headset several years ago to replace that and they worked great until a couple days ago when the mic came unconnected from the volume control PCB. I've ordered a pair of Turtle Beach TBS-2114 HPA2 5.1 Surround headphones so hopefully they work great :)