PDA

View Full Version : not even triggers work!


CiberX15
28th Nov 2008, 04:33 PM
What am I doing wrong? I was getting annoyed that in my scripting I couldn’t seem to get any functions to fire, so finally out of desperation I decide to look at how a trigger works. To make sure I under stood it I first set up a trigger and a trigger light to see if it would work. I told the trigger to print, “I have triggered ” on screen. When I walked near the trigger in game it printed “I have triggered” but the light didn’t turn on. Thinking maybe there was something off with the light I tried using a view shaker, again the trigger printed the message but no shaking! I have used triggers in the deus ex version of the editor so I know how to set the tags and events and they worked fine in that. I am beginning to think I got a bad copy of the runtime or something. Its like the software hates me!

Thanks for putting up with me.

Wormbo
28th Nov 2008, 04:36 PM
How did you set up the Trigger and light and what light class did you use?

Oh and in case you don't like talking to yourself, try the main coding forum instead of this special UE2Runtime subforum. You might actually get people looking at your threads there.

CiberX15
29th Nov 2008, 01:41 PM
I created a normal trigger and set its tag to "light". Then I used a trigger light and set its event to "light". Same with the view shaker.