View Full Version : UE1 - UT Weapon Model mesh going over HUD

29th Sep 2008, 10:55 AM
The problem I'm having is that the model is perfectly positioned the same way as any other custom or default model in the FirstPersonView of the weapon and it goes over the HUD blocking all ammo count and other info that it shows. I imported the meshes with the MilkShape 3D from one of the Quake3 MD3 files and animated it completely to export it as a .3d file in order to compile it into UT99. I never had this problem before until now. I'm not really sure if MilkShape is causing this glitch or if it might be a configuration somewhere in the gun. But I would like to fix this so I can finish my weapon mod asap. So, has anyone else had this issue and was able to fix it that can guide me to that knowledge for correct modeling? Does anybody know what causes the glitch I mention?

I will post a screenshot tomorrow if possible...

29th Sep 2008, 10:32 PM
This glitch usually occurs if the model is too small or rendered "too close to the player's view" (clipping plane). You can adjust the model offset in the default properties of the weapon, and then take care of the model scale either through the DrawScale property, or at importation/compile time by adjusting the values in the scalemeshmap directive.

30th Sep 2008, 03:08 AM
Thanks for the response meowcat. I have tried everything you've mentioned for the past week. I've made the model in Milkshape really big to fit a 512 grids and very small as its original 32 grids, none of those sizes in between was able to get rid of that glitch, which I find it extremely weird. I also messed around with the sizes while importing the mesh and even tried many sizes in the FirstPersonView as well, and it still went over the HUD.

I usually animate my models with a custom, very simple program that a friend wrote for me and that glitch never happened with it no matter how big or small the mesh was. The problem is that is not an accurate program to animate since it has no X,Y,Z control for Rotation or Move like the MilkShape does. And the biggest problem is that I cannot convert the file to a .T3D or a not glitched .3D format which is the only 2 that it imports from so that I could see if the problem is with the model or the file exported by MilkShape. I did try importing the .3D from MilkShape and exported it with my friends program to see if the glitch would be fixed but it still came out the same way. Now, I really don't know if this problem could be solved.

Another thing I was thinking of, was of the box (space in grids - max 1024x1024) where the model is animated in. My friend told me that if it is too big it could cause some consequences like probably the glitch I'm getting with MilkShape since it doesnt have a way to limit the box space that holds the model... from what I know. So what I wonder is, if that might be the glitch I'm getting with MilkShape's .3D format.

30th Sep 2008, 08:19 PM
Your friend was right about the too big size thing. If the vertex animated model sticks outside of a +128 box (256x256x256 cube centered on the origin) at any point during its animations, those vertices will be mapped/rolledover and end up on the other side. I highly doubt the problem is with Milkshape3D, I exported hundreds of models (both vertex animated for UT and later skeletal animated for UT/UT2k3/UT2k4). The only time I encountered similar problem was when the model got too close to the camera plane.

Unfortunately you may just have to live with adjusting the player view offset (or whatever it was called in U1/UT), but go ahead and post a screenshot if you can. Alternatively there *may* be a way to adjust the clipping plane through script...