PDA

View Full Version : proublem importing textures to UnrealED 2.0...


Helgso
25th Mar 2006, 04:08 AM
Hi, there is a little proublem here... I have imported texture but it just comes bad out...(see the picture) HELP!

Notice: I have imported my texture with .pcx format but it doesent work.
Some ideas?

Tidu
25th Mar 2006, 04:01 PM
Try using a different format, like .bmp or .dds and see if it's the same.

Ironblayde
25th Mar 2006, 04:21 PM
UnrealEd 2.0 only allows 8bpp (bits per pixel) on a texture. The PCX file format supports up to 24bpp, so my guess is that your texture's color depth is too high. Use an image editor to drop it down to 8bpp, then save and import that version and you should be fine.

OutlawSkot33
25th Mar 2006, 10:27 PM
Import it in .bmp format. Its really the only format that imports correctly in 2.0

Never have I seen .pcx import correctly, only .bmp.

Helgso
26th Mar 2006, 05:54 AM
humm

Helgso
26th Mar 2006, 06:06 AM
It did not work... It worked to import the texture but when i did go to level info and was going to open the LevelInfo tab it just came this way(see picture) and i am really unhappy that it is not working with me... It is unfair... And when it woks(sometimes) it appear black in Unreal Tournament

Wulff
26th Mar 2006, 06:15 AM
Just have the image be a .pcx and at 8 bits per pixel, only way for it to work properly everytime.

Ironblayde
26th Mar 2006, 01:10 PM
Import it in .bmp format. Its really the only format that imports correctly in 2.0

Never have I seen .pcx import correctly, only .bmp.
I use .pcx for importing textures into UnrealEd 2.0 all the time and have never had a problem with it.

Helgso, if you do decide to try the .bmp format instead (it's worth a try), make sure you save your .bmp file using RGB encoding. In my experience, UnrealEd 2.0 won't import a .bmp that uses RLE compression. Though now I wonder if that problem is just something I experience, like OutlawSkot33's difficulties with the .pcx format.

If all else fails, could you upload the texture you're trying to import so I can give it a try? At least that way we'll be able to tell whether you're doing something wrong in the import process, or if it's a problem with the texture itself.

Helgso
27th Mar 2006, 10:32 AM
Here is the texture i am trying to import. But it is a screenshot not a texture. I am trying to import it to my map so i could see a picture of it when i am playing Unreal Tournament. But here is the screenshot:

Ironblayde
27th Mar 2006, 11:08 AM
The problem is exactly what I said it was above: you're trying to import a 24bpp image, which UnrealEd 2.0 does not allow. You need to reduce it to 8bpp first, which you can do with any image editor. I've converted this one for you.

Helgso
27th Mar 2006, 02:58 PM
hey can you teach me how to do that? (i am so much N00b about doing that) But one proublem... now it all worked except the screenshot is not showing up in Unreal Tournament map select even if i open my map in UnrealED, did go to levelinfo, levelinfo tab and located it to my screenshot to mylevel texture package. strange... (could i upload my map and my texture wich you converted to 8bpp and you could do it for me IronBlayde?)

Ironblayde
27th Mar 2006, 09:37 PM
Here's a detailed explanation of how to set the screenshot for your map. Please make sure you follow these steps exactly:

http://wiki.beyondunreal.com/wiki/Screenshot_(UT)

I can't teach you how to reduce the color depth of an image unless I know which image editor you're using. I use Photoshop 7.0, and the relevant option is found at Image -> Mode -> Indexed Color. I also have an old version of Paint Shop Pro where the option is called Decrease Color Depth. In some editors you can select the color depth you want as part of the save process. So what are you using?

Kantham
27th Mar 2006, 09:52 PM
It's spelled "problem", not Proublem.

Ironblayde
28th Mar 2006, 12:36 AM
Thanks for your contribution, Kantham. That's sure to fix his proublem.

Helgso
28th Mar 2006, 08:43 AM
I use Gimp2 and Paint in windows... I have looked at the wiki but it is not helping me anyway so... I dont know what to do next...

Ironblayde
28th Mar 2006, 11:40 AM
The GIMP's menu structure is pretty similar to that of Photoshop. Load your image and select Image -> Mode -> Indexed. On the dialog that comes up you can just leave the default settings (should be Generate Optimum Palette with a maximum of 256 colors). Then save the image as a PCX file. You can also save it as a BMP, but if you do so, do not check the box for RLE compression during the save process, as UnrealEd 2.0 doesn't seem to handle that properly.

neilthecellist
28th Mar 2006, 07:57 PM
Thanks for your contribution, Kantham. That's sure to fix his proublem.

Never say that to someone who has an obviously higher postcount than yours, even if you think you're right.

By the way, Kantham's right. :) We love ya. (not THAT way you other pervs)

Ironblayde
28th Mar 2006, 10:29 PM
By the way, Kantham's right. :)
Obviously! I just thought it was strange to come into a thread like this for the sole reason of pointing out a spelling error, and figured I'd seize the opportunity for a sarcastic response.

Helgso
29th Mar 2006, 09:48 AM
See: I have done every single part right. The pictures are in right row. just veiw them and see.

Kantham
29th Mar 2006, 10:59 AM
IIRC i had problems with importing sounds in UED 2.0. Try puting the file in C:/ instead of "My documents". Just a test, it might be a problem. And change the pic name to 'ctfwarehouse' instead of 'ctf-warehouse'.

Helgso
29th Mar 2006, 11:15 AM
IIRC i had problems with importing sounds in UED 2.0. Try puting the file in C:/ instead of "My documents". Just a test, it might be a problem. And change the pic name to 'ctfwarehouse' instead of 'ctf-warehouse'.

That was not the problem. I tested it. It didn't work.

Ironblayde
29th Mar 2006, 12:29 PM
See: I have done every single part right. The pictures are in right row. just veiw them and see.
No, you didn't follow the instructions on that page I linked to. Look again:

http://wiki.beyondunreal.com/wiki/Screenshot_(UT)
Import the screenshot into UnrealEd. This procedure is described fully in Texture Import And Export. Briefly, use the following settings in the Import dialog box:

Package: MyLevel
Subgroup: (leave it blank)
Name: Screenshot
Uncheck the "Generate MipMaps" option.

You have the group and the name wrong.

Kantham
29th Mar 2006, 12:34 PM
Mhhh, UED 2.0 is very capricious as i couldn't remember.

Helgso
29th Mar 2006, 01:18 PM
No, you didn't follow the instructions on that page I linked to. Look again:

http://wiki.beyondunreal.com/wiki/Screenshot_(UT)

You have the group and the name wrong.

THX!!!! THIS HAVE BEEN SO MUCH TROUBLE AND YOU COME FIX EVERYTHING!!! THX!!!!