PDA

View Full Version : Can't load a saved SA session


Giftmischer
9th Feb 2006, 03:58 AM
Hi,

you've made a great mod, but there's something which disturbs me:
I can't load a saved SA session.
Even when I try this, I come back to the current game session or, when I haven't start a new game session, I come back to the intro screen.

What's wrong?
Is there something special I have to configure?


Greetings,

Giftmischer

livingtarget
9th Feb 2006, 04:16 AM
Hmm that's strange is that happening with the latest build? It works with my build at home, but I have seen stuff like this happening before.

Meanwhile could you attach the SaLog.log in your UnrealTournament/System/ folder or /home/~Your UserName~/.loki/System/ on linux it should tell you whats up. Most likely some file missing or it might only happen in certain maps.

And one last thing if you saved a game in v0.2 you are quite likely that i might not run on version 0.3.

Giftmischer
9th Feb 2006, 04:54 AM
Thnx.

I have v0.3 and play this UT mod on windows.
In the SaLog.log is something about "failed load session".

#EDIT:
SaLog.log + I have found something about "failed loading" in the log file.

livingtarget
9th Feb 2006, 01:26 PM
This is normal:
..\Save\Save3.usa?Name=LivingTarget?Class=Botpack.TMale2?Team=2?Skin=?Face=?Voice=?Game=?load
This is you:
..?Game=SaGame.JzGame?Mutator=?Name=Giftmischer?Class=MultiMesh.TSkaarj?Team=2?Skin=?Face=?Voice=?lo ad#Save\Save0.usa

Also when I save:
Log: Moving '..\Save\Save.tmp' to '..\Save\Save0.usa'
You:
Log: Moving '../Save\Save.tmp' to '../Save\Save0.usa'

Which is a bit odd, check if you have a \Save\ folder in your unreal tournament directory.

Here's a few things to try if you can.

My own INI the settings are pretty safe, replace it with the one you've got in \System\
http://sa.beyondunreal.com/SilentAssassins.ini (save as)

Try the latest code, it might help:
http://sa.beyondunreal.com/SaGame.zip

In the SaUser.ini, try get the following thing:
Class=Botpack.TMale2
skin=SoldierSkins.blkt
Face=SoldierSkins.Othello

Instead of MultiMesh.TSkaarj

If that doesn't help I wouldn't know what to do, but see how you get on.

Giftmischer
9th Feb 2006, 02:24 PM
I'm thanking you for your great advices, livingtarget!!!

ALL WORKS!!! Very fine.

Now it's really fun playing SA!!! :)