PDA

View Full Version : [DA2 v1.0.0] UnrealEd Crashes when loading DA2 maps


Enfyrneaux
7th Oct 2005, 12:02 PM
EDIT - See fix in reply below...

Almost every DA2 map gives me one of these two errors (Classic Ruins opened, but with missing packages)...

Build UT2004_Build_[2004-11-11_10.48]

OS: Windows XP 5.1 (Build: 2600)
CPU: AuthenticAMD PentiumPro-class processor @ 2071 MHz with 1023MB RAM
Video: NVIDIA GeForce FX 5600XT (5672)

Ran out of virtual memory. To prevent this condition, you must free up more space on your primary hard disk.

History: FMallocWindows::Malloc <- FMallocWindows::Realloc <- 00000000 2009820394 FArray <- FArray::Realloc <- 2009820394*1 <- UStruct::Serialize <- (Class myLevel.da_objective_Touchable0) <- UState::Serialize <- UClass::Serialize <- (Class myLevel.da_objective_Touchable0) <- LoadObject <- (Class myLevel.da_objective_Touchable0 2846466==2846466/13650243 2846426 302) <- ULinkerLoad::Preload <- PreLoadObjects <- UObject::EndLoad <- UObject::LoadPackage <- UEditorEngine::Exec_Map <- UEditorEngine::Exec <- (MAP LOAD FILE="C:\UT2004\DA2\Maps\DA2-Triumph.ut2") <- UUnrealEdEngine::Exec <- FileOpen <- WEditorFrame::OnCommand <- WWindow::WndProc <- WWindow::StaticProc <- MessagePump <- MainLoop



Build UT2004_Build_[2004-11-11_10.48]

OS: Windows XP 5.1 (Build: 2600)
CPU: AuthenticAMD PentiumPro-class processor @ 2082 MHz with 1023MB RAM
Video: NVIDIA GeForce FX 5600XT (5672)

Assertion failed: Actors(1)->Brush!=NULL [File:c:\ut2004build\ut2-code\engine\inc\UnLevel.h] [Line: 430]


I tried fixing this by looking for any EditorPackages lines in the UT2004.INI file, but I couldn't find anything similar (I've only done mod mapping for UT99, with AirFight and DA:CE).

DA|Dante
7th Oct 2005, 01:58 PM
Hmm I thought we had a correct unrealed link. As it seems not.
To use unrealed with da2 call it with:
unrealed -mod=da2

DA|aBsOlUt
7th Oct 2005, 02:29 PM
Apologies for forgetting the shortcut, what Dante should make it work

Enfyrneaux
7th Oct 2005, 03:17 PM
It works :):tup:
Thanks guys!