PDA

View Full Version : USB Troubles


QUALTHWAR
8th Sep 2005, 12:30 PM
Iím trying to figure out what is going on with my USB ports. Iíve had this Logitech headset for over a year and when I first bought it, I had no trouble when I plugged it in. Now, Iím having problems with it and other things like my digital camera and my scanner.

I have XP Pro and I was getting nothing from my headset when I plugged it in so I went into the sound configuration and selected the USB headset as my default playback. That worked when I tried playing an MP3, however my speakers have always been the default playback and the headset still worked. I have ďuse only default devicesĒ unchecked on my Audio tab.

Anyway, although that got my music working, my WinTV gave me an error and would not open. WinTV would open if I set the default playback to my speakers, but I had no sound with WinTV. I ended up going into my hardware devices and deleting all the USB devices and the Human devices. Then I rebooted and the PC found the USB devices and installed the drivers. Then when I plugged my headset in, it found the headset and set it up and that worked for one of my four 2.0 ports until I tried adjusting the volume for WinTV. So, I plugged the headset into my second USB port and it configured that and my sound worked fine through the headset. I could hear WinTV and MP3s. I left things alone after that.

I shut the system down last night and tried the headset today and nothing. Now, I also have this HP scanner that seems to only work if I load the drivers and not shut off the PC. If I boot back up, I have to install the drivers again. And, my digital camera isnít recognized when I plug it in sometimes. I have to unplug it and try again a time or two.

I have four 2.0 USB ports on the front and Iíve tried them all, so I donít think itís a connection problem at the plug. I have two 1.1 plugs in the back, but I donít ever use those. This seems like a conflict with my system. Something is screwing with my settings and fudding things up. I noticed yesterday, after plugging in the headset a bunch of times, I finally got an error saying the device was not recognized. Any ideas?

Cat Fuzz
8th Sep 2005, 09:05 PM
Well, I'm befuddled. :hmm:

OO7MIKE
8th Sep 2005, 09:52 PM
Install a service pack recently?

SpiritWalker
8th Sep 2005, 10:47 PM
ouch.....

try.....

using just that USB device... with no other USB devices hooked up.. if it works that way.. you may want to check you IRQs.. probably not the issue.. but if you were working with any other type of device that's where I would begin

QUALTHWAR
9th Sep 2005, 11:18 AM
I got things working for now, but who knows how long that will last. Since there are no drivers for my headset or camera, I decided to check into FAQs for my HP scanner. I found a FAQ with my exact problem. It said to go into my USB root hubs and turn off the power management feature. It said the ports werenít waking up like they should be. This seemed to make sense with my scanner and my camera, and maybe my headset.

So after installing new drivers for my WinTV, I deleted all the USB root hubs from the device list, rebooted, let it find the hubs and set them up, then I turned off the power management to all the hubs. I tired my first port and my headset worked. I rebooted and my headset still worked. I tried my scanner and it worked. I think I have it now.