PDA

View Full Version : Wrong map prefix bug back in v50?


Da Kril
25th Apr 2005, 12:58 AM
I have noticed the old "incorrect map prefix for voted game type" problem in the new v5.0 of UT2Vote. It was gone in v49, but seems to be back now, in a limited way.

I am only seeing it when the game type is initially changed from the server default (like when you join after UT2Vote's put the server back to default game type and map). Our server default is CTF, and map is CTF-FaceClassic.

The first vote to new game type always results in a window of CTF maps, no matter what the new game is. It doesn't seem to happen any other time (at least, I have not noticed it).
EDIT: Nope, not all game types. Only games that use the DM prefix. It happens always when voting from CTF-anything to a game type that uses DM-. My bad.

Any help, ideas, or workarounds?

Thanks in advance, :D
Da Kril

ProAsm
25th Apr 2005, 01:06 AM
Thanks for this, we will look into it asap.
Btw, try and not use a custom map as the games DefaultMap - always use an original vanilla map - like CTF-Chrome etc..

Da Kril
25th Apr 2005, 10:44 AM
Thanks for the quick response! And roger using vanilla map (although I think FaceClassic is about as vanilla as you can get). :D

Da Kril

ProAsm
26th Apr 2005, 03:27 AM
After many games and votes I just cannot get this to happen.
1. I start the server with defaultgame as CTFGame.
2. We vote the game to a DeathMatch game and play for a while.
3. We then all leave the server so 3 minutes later it switches to the defaultgame - being CTFGame.
4. We then join the server and vote for another game type, but everytime the correct maps are displayed.
In fact we tried several different combinations but everytime everything worked ok.

So... could you please give an exact proceedure on how we can replicate the problem as unless we can replicate the problem here, there is no way we can fix it.
Also post your GameType= strings for the games that you have the problem with.

Thanks ;)

Da Kril
26th Apr 2005, 02:09 PM
Hmmn, OK, well after further inspection, it doesn't just happen after the server's reset itself to default CTF (that's just when I've been noticing it), it happens when voting from "CTF-any map" to any kind of DM game that uses DM-prefixed maps, including DM, TDM, Mutant, etc.

Example: You are in CTF, you call up the UT2Vote menu with the home key, vote for Mutant as the game type. It says "Switching to New Game" and pops the vote menu back up with maps. They are all CTF maps.

A work-around is if you close the vote window and then re-open it, you will see the proper "DM-" map list. (this is like v48, iirc)

However, if you vote for, say, Onslaught from CTF, the map list correctly displays ONS maps. It's only the DM- game types where it sticks with the CTF maps.

Here is the game string I have for CTF:
GameType=(GameName="FnG-Capture the Flag",HideVote=False,Clan=True,RequiredPlayers=1,MapLimits=0,ServerName="None",UseMapList=False,DefaultMap="CTF-FaceClassic",MapPrefix="CTF",AltMapPrefix=,GameClass="XGame.xCTFGame",Mutators="None",Commands="?MaxLives=0?GoalScore=5?TimeLimit=20?MinPlayers=2?MaxPlayers=16?MaxSpectators=4?Translocator=True?We aponStay=True?BalanceTeams=False?ForceRespawn=False?PlayersMustBeReady=False?Tournament=0?GamePasswo rd=?GameStats=True?GameSpeed=1.00?FF=0.00?NoOverTime=False?VsBots=False?NumBots=1?Difficulty=3?bCust omGame=True")

For grins, here is my DM game string:GameType=(GameName="FnG-DeathMatch",HideVote=False,Clan=False,RequiredPlayers=1,MapLimits=0,ServerName="None",UseMapList=False,DefaultMap="DM-Rankin",MapPrefix="DM",AltMapPrefix=,GameClass="XGame.xDeathMatch",Mutators="None",Commands="?MaxLives=0?GoalScore=40?TimeLimit=20?MinPlayers=2?MaxPlayers=16?MaxSpectators=4?Translocator=False? WeaponStay=True?BalanceTeams=False?ForceRespawn=False?PlayersMustBeReady=False?Tournament=0?GamePass word=?GameStats=True?GameSpeed=1.00?FF=0.00?NoOverTime=False?VsBots=False?NumBots=1?Difficulty=4")

The only server-wide mutator running (other than UT2Vote) is Wormbo's PingCompensation2, btw.

You are welcome to try this for yourself: my server is at 66.55.134.30.
(I will send you the password privately)

Thanks again, :D
Da Kril

ProAsm
27th Apr 2005, 05:05 PM
Thanks we are testing atm.

ProAsm
29th Apr 2005, 09:34 AM
Example: You are in CTF, you call up the UT2Vote menu with the home key, vote for Mutant as the game type. It says "Switching to New Game" and pops the vote menu back up with maps. They are all CTF maps.mmm we do not get this to happen, it does what its supposed to do everytime, regardless of what combination we use and what Game we vote for, the correct maps for the new game are always displayed correctly.
However, going back in our archives we found that we had this problem once before and the problem only occured on slow servers where it took a long time for the new map replication to reach the client, hence the reason why it works when you close then re-open the menu.
UT2Vote is designed around servers that have pings better than 200 with not more than 5% packet loss and NetSpeeds of not less than 4500.
Testing will still continue to see if we can get your problem to happen.

Just a point with your GameType= string, AltMapPrefix= cannot just be blank, it must be AltMapPrefix="" to be represent blank.

ProAsm
1st May 2005, 03:39 AM
Ok after a lot of testing we finally managed to get this to happen on the odd occasion, but it only happens when voting for a new game during the game, at game end it works correctly everytime.
*** Edit ***
Actually cancel that, the person that was seeing this problem was using a 900 Celeron :(

ProAsm
1st May 2005, 04:13 AM
Hang on - just a thought here ?
Example: You are in CTF, you call up the UT2Vote menu with the home key, vote for Mutant as the game type. It says "Switching to New Game" and pops the vote menu back up with maps. They are all CTF maps.During a game it will say "< THE VOTE WAS PASSED >" - at Game End it will say "< MAJORITY VOTE REACHED " and only if there is one player playing the Bots will it say "Switching to New Game" ???
So you are playing a Bot and not Payers and here we have all the players scratching their heads :)
I will try it with a Bot and see what happens now.
** Edit **
Ok works great with a Bot also.