PDA

View Full Version : [UT'99] why sound is so low


Raven
7th Apr 2005, 03:57 PM
I write code for lightning. The problem is, that sound is played too low, and I don't know what I need to do, to make it work properly. Here is code:


class TCOLightningSound extends TCOLightning;

#exec OBJ LOAD FILE=..\Sounds\AmbOutside.uax PACKAGE=AmbOutside

var() sound LightningSound;
var() byte LightningVolume;
var() bool LightningbNoOverride;
var() byte LightningRadius;

function PlayThunder()
{
PlaySound(LightningSound, SLOT_None, float(LightningVolume)*128, LightningbNoOverride, float(LightningRadius)*25);
}

defaultproperties
{
Texture=Texture'CHSystem.Icons.LightningS'
LightningSound=Sound'AmbOutside.OneShot.thunder'
LightningVolume=255
LightningbNoOverride=false
LightningRadius=255
}

Asgard
10th Apr 2005, 03:29 AM
Well it might be that youre trying to set the sound way too high. So high that its defaulting to 1. Even the 255 setting is too high that's an ambient sound setting not really a playsound setting. I believe the playsound works by multipliers,so youre trying to multiply the volume by 255 by 128. The highest Ive ever seen a playsound setting is 10. Most cases its seems it has no problem reducing volume but when trying to make it louder doesnt work too well.. try reducing the amount youre trying to multiply the volume..

If thats not loud enuff export the sound and use a sound editing program to boost the imported sounds volume. if you keep the sound to a 8 bit or 16 bit sound it wont blow out your mod too much and will be barely noticable..

for a read by Tim sweeny
http://unreal.epicgames.com/Audio.htm

cheers