PDA

View Full Version : -ini=xxxxx.ini doesnt work


Guyver1
10th Dec 2004, 04:50 PM
ok ive got 2 servers running on 1 box

195.224.41.44:7777 runs fine and uses ther default UTXMP.ini file

when i try and run my second server on port 8888 using a copy of hte default ini called UTXMP2.ini using this command line:

nohup ./ucc-bin server XMP-Garden?Game=XMP.XMPGame -mod=UTXMP -ini=UTXMP2.ini -log=UTXMP2.log -nohomedir > /dev/null &

the server log shows that its trying to use the UTXMP.ini that server 7777 is using and its ignoring my -ini= switch

this appears to only happen when using hte -mod= switch

any idea how to fix???

Dandeloreon1984
10th Dec 2004, 04:55 PM
ya, have you thought of integrating utxmp into ut2k4, that way u can use this:

./ucc-bin server XMP-Garden?Game=XMP.XMPGame -ini=UTXMP2.ini -log=UTXMP2.log -nohomedir > /dev/null

and for the other server:

./ucc-bin server XMP-Garden?Game=XMP.XMPGame -ini=UTXMP1.ini -log=UTXMP1.log -nohomedir > /dev/null


note, a good example ini is the ini... c:\(your 2k4 install directory)\UTXMP\System\UTXMP.ini

just copy that into your system directory, and not use the -mod flag.