PDA

View Full Version : Sound Volume


FF7fan
1st Nov 2004, 05:48 PM
I've been trying to import sounds into UED but when I do the editor makes the volume of the sound very low and when I actually hear it ingame, I have to turn my speakers up very loud to hear it properly. The sound quality is going down because I've tried turning up the volume but it's still way too low. Is there a way to bring up the volume of my sound? Oh, and these are mover sounds so I can't see how to control the sound radius and such.

chip
8th Nov 2004, 01:29 PM
this has been commented and asked about by many, including quality voice-pack makers, but tmk there hasn't been a definitive reply from Epic. probably the best step you can take is to optimize the volume in the WAV file by using a sound editor to filter and normalize and amplify, getting the max peak amplitude without clipping or distortion, and then importing. i've found that a WAV that plays back at reasonable volume in any of my audio editing or playback apps is quite a bit fainter in UEd, so i tweak the WAVs to really blast & rumble ;)

MrBond
8th Nov 2004, 02:23 PM
The solution may lie in the bitrate and quality of the sound itself.

I remember reading somewhere that UT does not support sounds greater than 22khz (you can find proof in the audio section of preferences). Also, I don't think stereo is supported. Try converting your sounds to 8-bit Mono, 22khz.

chip
8th Nov 2004, 05:36 PM
i've imported the same WAV file @ 44 KHz and 22 KHz and can discern no diff in the audio qualities, so though 16 bit mono @ 22KHz is a common set of specs, i don't think it impacts the volume problem.

export one of the Epic sounds and check the waveforms -- most of the peak volumes are maxed, and a great deal of the mid-range amplitude is well above "normalized" levels. they also play back in my audio editor (Audacity) at a higher volume than in UEd (from the Sounds browser), just as do custom sounds.

MrBond
8th Nov 2004, 05:48 PM
I think the key is the Stereo/Mono setting. To my knowledge, UT does not support stereo WAVs. If it encounters a stereo sound, it'll take one channel, and since a stereo sound consists of two channels, the volume will be halved. Converting to mono combines the channels, thus resulting in one channel that UT recognizes.

Try it. I've had this problem before, and using mono fixed it.