PDA

View Full Version : Error and Warning in Logfile


[SNC]SoKoBaN
26th Sep 2004, 06:53 AM
I have installed UT2Vote46 and i have aLot of Warnings and Errors in my Logfile.
Error: UT2VoteX DM-Deck17.UT2VoteX (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Accessed array 'GameType' out of bounds (46/11)
Warning: UT2VoteX DM-Deck17.UT2VoteX (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Attempt to assign variable through None 'DefaultMap'
Warning: UT2VoteX DM-Deck17.UT2VoteX (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Attempt to assign variable through None
Error: UT2VoteX DM-Deck17.UT2VoteX (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Accessed array 'GameType' out of bounds (46/11)
Warning: UT2VoteX DM-Deck17.UT2VoteX (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Attempt to assign variable through None 'DefaultMap'
Warning: UT2VoteX DM-Deck17.UT2VoteX (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Attempt to assign variable through None
Error: UT2VoteX DM-Deck17.UT2VoteX (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Accessed array 'GameType' out of bounds (46/11)
Warning: UT2VoteX DM-Deck17.UT2VoteX (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Attempt to assign variable through None 'DefaultMap'
Warning: UT2VoteX DM-Deck17.UT2VoteX (Function UT2Vote46.UT2VoteX.GetCurrentGame:02C2) Attempt to assign variable through None

sh0V3l
26th Sep 2004, 11:25 AM
SoKoBaN']I have installed UT2Vote46 and i have aLot of Warnings and Errors in my Logfile.

can you give us more info such as startup commandline any mods or muts your running or even better post your ut2vote46.ini the more info the faster we can figure out whats causing this thanks :)

ProAsm
26th Sep 2004, 02:39 PM
Looks to me as if he's duplicated the game classes as there are 11 or 12 default games, hence the out of bounds - just a guess.

sh0V3l
26th Sep 2004, 04:11 PM
ya thats what i was thinking thats why i wanted to see ut2vote.ini :)

Fisch.666
28th Sep 2004, 03:55 PM
Hi!

I have the same problem with my UT2004 Linux Dedicated Server (v3323) and UT2Vote 4.6.

Installed Muts:

AntiTCC 1.18c + AntiBypass Tool
ServerExt-v105b
OlStats 2.20

Installed Mods:

Carball 2.0
AlienSwarm 1.1
Fraghouse Invasion v3.1
BlastArena 2k4
DeathBall 2.2
Jailbreak 2004a
Clone Bandits
HappyFunBall
Unreal Demolition Beta3

Startline:

./ucc-bin server DM-Antalus.ut2?game=XGame.xTeamGame?GameStats=true?Mutator=UT2Vote46.UT2VoteX -nohomedir -lanplay log=/home/chris/ut2004/UserLogs/server.log ini=ut2004.ini

And my Ut2vote46.ini is attached at this post...


Thanks in advance for your replys.

ProAsm
28th Sep 2004, 04:22 PM
Just looking through your ini file you have some real wierd stuff there.
UnrealDemolition.UD.GameName, UnrealDemolition.UDDemoBall.GameName, etc etc, not sure where you got these from as they are not Classnames and are illegal.
I see in each case there is a '.GameName' what is that and where did it come from, maybe try removing those '.GameName' as they are illegal.

Fisch.666
28th Sep 2004, 04:44 PM
Hi Proasm,

thanks for your reply.

I took the .GameName entry from the .ucl files because i thought i have to use this.
After removing this entrys, the errors dissaprare.

Thanks for your hint!!!

Fisch.666
28th Sep 2004, 04:58 PM
Hi!

Sorry, i've posted this to early.

The errors and warnings are still in the logfile. :(

ProAsm
28th Sep 2004, 05:30 PM
Post the .ucl file that you are refering to.

Fisch.666
28th Sep 2004, 06:27 PM
Hi!

Post the .ucl file that you are refering to.

This is the .ucl File from UnrealDemolition.

I use

Game=(ClassName=UnrealDemolition.UD, GameName=UnrealDemolition.UD.GameName,TeamGame=0,GameAcronym=UD,MapPrefix=UD,Screenshot=UDHUD.uddmin tro,MapListClassName=UnrealDemolition.UDMapList,HUDMenu=UnrealDemolition.UDHUD,Description=UnrealDem olition.UD.Description,FallbackName="Unreal Demolition",FallbackDesc="The classic sport of Demolition Derby brought to your living room. Battle in a intense free for all in unique arenas built for serious combat and insane tricks.")

instead of:

Game=(ClassName=UnrealDemolition.UD,GameName=UnrealDemolition.UD.GameName,TeamGame=0,GameAcronym=UD, MapPrefix=UD,Screenshot=UDHUD.uddmintro,MapListClassName=UnrealDemolition.UDMapList,HUDMenu=UnrealDe molition.UDHUD,Description=UnrealDemolition.UD.Description,FallbackName="Unreal Demolition",FallbackDesc="The classic sport of Demolition Derby brought to your living room. Battle in a intense free for all in unique arenas built for serious combat and insane tricks.")

ProAsm
29th Sep 2004, 02:17 AM
Well you are wrong.
UnrealDemolition.UD
That is what you need in the GameClass= part ot the GameType= string in UT2Vote.

,GameClass="UnrealDemolition.UD",Mutators="etc etc etc......

Fisch.666
29th Sep 2004, 01:38 PM
Hi!

Yes, i know i'am wrong. But i've remove all .GameName entry's from my ut2vote.ini but the errors and warnings are are still in the server.log.

Any other ideas?

Thanks in advance for your replys.

ProAsm
29th Sep 2004, 02:13 PM
Ok, well what I did is I used your UT2Vote46.ini file as is on my server and I dont get those warnings and errors that you are getting so it something else, maybe some mutator or serveractor causing a clash with UT2Vote.
When do these errors occur, all the time or only when you vote for one of those games.
Maybe you should post your log file as well as it might tell me a story ;)

Fisch.666
29th Sep 2004, 03:45 PM
Hi!

This happens all the time with or without players on the server.

I've attached the server.log at this post.

Thanks again for your help!

ProAsm
29th Sep 2004, 04:30 PM
Ok just a few things.

Firstly your commandline is:
DM-Antalus.ut2?game=XGame.xTeamGame?GameStats=true?Mutator=UT2Vote46.UT2VoteX

You cannot have any other command on the commandline except UT2Vote.
Also there is no extension to the map - so it should be:

DM-Antalus?Game=XGame.xTeamGame?Mutator=UT2Vote46.UT2VoteX

Then add the GameStats to:

ServerLine=?GameStats=True

The above will not stop the errors.

I see you run several other muts - dump them all except UT2Vote, check your logs and slowly add the muts back one by one till the error occurs.
I also see UT2Vote loads long before AntiTCC yet the errors only happen after AntiTCC is loaded - that alone speaks volumes.

You just gonna have to fiddle with the commandline and mutators.
As I say using your ini everything works 100% here so it has to be the way you starting your server.
Btw the -nohomedir and the -lanplay is not really needed so dump that also.
Also your -ini=UT2004.ini should come before your -log
Also writing the log across the lan to another pc must be causing a lot of unecessary lag.

Fisch.666
30th Sep 2004, 03:48 PM
Hi!

First of all thanks for your hints/suggestions. :2thumb:


Firstly your commandline is:
DM-Antalus.ut2?game=XGame.xTeamGame?GameStats=true?Mutator=UT2Vote46.UT2VoteX

You cannot have any other command on the commandline except UT2Vote.

Then add the GameStats to:

ServerLine=?GameStats=True


I had this ?Gamestats=true in entry in the commandline and ut2vote46.ini so i remove it from the commandline.


Also there is no extension to the map - so it should be:


Then the guys at www.unrealadmin.org should update their tutorials:

http://www.unrealadmin.org/forums/showthread.php?t=49


I see you run several other muts - dump them all except UT2Vote, check your logs and slowly add the muts back one by one till the error occurs.


Ok, i will do this now and post here again when the error dissapear.


I also see UT2Vote loads long before AntiTCC yet the errors only happen after AntiTCC is loaded - that alone speaks volumes.


This error happen ca. 5 min. after the server is fired up, not directly after AntiTCC is loaded.


Btw the -nohomedir and the -lanplay is not really needed so dump that also.
Also your -ini=UT2004.ini should come before your -log


Ok, i will do so too.


Also writing the log across the lan to another pc must be causing a lot of unecessary lag.

What do you mean with this? The log's are written on the server, not on another pc in my lan.

ProAsm
30th Sep 2004, 04:05 PM
Oh, well you have in your commandline:
log=/home/chris/ut2004/UserLogs/server.log

If its directly to the PC then all you need is:
log=server.log

Regarding the map extension, you can have it eitherway its just good practice to leave it out is its not necessary :)

Fisch.666
30th Sep 2004, 04:59 PM
Hi!

Problem solved!!! The error went away after i remove the 3 mutators included in the CBP 1+2 from my server and follow your hints in your post above.

Oh, well you have in your commandline:
log=/home/chris/ut2004/UserLogs/server.log

If its directly to the PC then all you need is:
log=server.log


But then the server.log is placed in my /System/ folter. I added this line to have the server.log in my /UserLogs/ folder. :)


Regarding the map extension, you can have it eitherway its just good practice to leave it out is its not necessary :)

After i remove the extension another problem went away. With the extension the server switched after the startup from DM-Antalus.ut2 to DM-Antalus as you can see in the server.log. Without the extension this never happens again.