PDA

View Full Version : August 12 2004 bug thread


jerdaygo
12th Aug 2004, 10:21 PM
I wanted to start a new bug thread with this version because it has eliminated a few major bugs and hope to start a thread with some more minor ones, I havent had a chance to test very much yet but here are some things that do work now

All of these are with Online testing

1 The out of bounds works
2 The out of bounds counter works much better now
3 The dropCam works Online
4 The FlipMe function now works Online, I assume you are going to be able to bind a key for this in the future, so i will not mention it :)
5 The place counter still doesnt work it allways says 0/0
6 The Xcelerator OWNS!!!!, but there is a little flicker in the texture of the wing/fin
I will playtest some more Online and other gametypes but I just wanted you to know what was new

Go Shrimp things are looking GREAT :) :D :D :D :D :D :D :D :D
:notworthy: :notworthy: :notworthy:

UltraNew-B
12th Aug 2004, 11:19 PM
The build is missing the re-reupdated static mesh packages I uploaded with the aug11 rar. :(

ProjectX
13th Aug 2004, 03:44 AM
OK:

Wheels of XCelerator don't touch the ground properly (they float)

XCelerator skin needs to be mirrored onto the other side too.

For the rest of the bugs on this version I've sent the URL and username/password to all dev members of the new wiki (although the host is having probs atm.) and there you can find the problems and ideas and future deadlines, features etc. that Shrimp and Jerdaygo and I have devised (nobody else has found it yet it seems)

UltraNew-B
13th Aug 2004, 10:32 AM
Shrimp uploaded the re-paired Static Mesh Packages he initially forgot, you can find them @ ftp/ec updates/08-13Aug-Statics.rar, so everyone get that if you have not already. :)

- Nothing can be done about mirrored texture on Excelerator
- Alote of cars still have incorrect textures, wheel radius's (floating wheels) applied still. There is a read me file included in the aug11.rar that lists all the texture problems in detail.

- excelerator wheel radius , uc setting, needs to be changed to 23.129, to stop the floating.

jerdaygo
13th Aug 2004, 11:21 AM
Shrimp uploaded the re-paired Static Mesh Packages he initially forgot, you can find them @ ftp/ec updates/08-13Aug-Statics.rar, so everyone get that if you have not already. :)

- Nothing can be done about mirrored texture on Excelerator
- Alote of cars still have incorrect textures, wheel radius's (floating wheels) applied still. There is a read me file included in the aug11.rar that lists all the texture problems in detail.

- excelerator wheel radius , uc setting, needs to be changed to 23.129, to stop the floating.

I seem to remeber TDA having a fix for the mirrored texture, but i may be wrong, and he is on holiday at the moment :( for us :) for him ;)

Kippenijzer
13th Aug 2004, 02:05 PM
I could be stupid (I am... I aaaaaaammmm :P), but are these closed beta releases under all you coding ppl, or are all other ppl allowed to test it as well (I couldn't find any links where to get it :S)

jerdaygo
13th Aug 2004, 03:15 PM
These are internal beta playtests, but hold on this next release is going to OWN and is will be out pretty soon. :D

Kippenijzer
13th Aug 2004, 03:34 PM
have been waiting for an actual working one (online play that is) for quitte a while now, and reading all these svehilce threads and this one does make my hands itch :)

ProjectX
14th Aug 2004, 03:34 AM
It'll be great, trust me. Just wait until you can do barrel rolls in JumpCity.

EDIT: Another bug - he Xcelerator has the airmovement stuff commented out, cos it won't barrel roll.

EDIT2: Ok, these are the bugs posted on the wiki that (to my knowledge) haven't been fixed. Som of you seem allergic to the page but it's best if everybody knows about them so they can fix them:

A lot of maps have Headlights = True turned on in their level properties, despite that they're in daylight. This will waste FPS.

City Track has a recommended player load of 6-10 players, but the description says it's for up to 9 players.

Jump City has Outofbounds Volumes that overlap with the track
This happens especially on the first corner, after the loop. If you scrape against the barrier you will reset

The Siren has no env map (shiny coat)

All Car Interiors are too shiny
Perhaps seperate mapping for the interiors w/ environment maps?

If any of these have been fixed (I haven't had a chance to throughly test it out yet) then ignore them.

UltraNew-B
15th Aug 2004, 07:14 AM
- Jump cam is really cool !!!!
- Scoreboard ownz !
- Reset makes life easy !

Found a pretty serious bug in the 11/15 build:

I played the new big air map, jump city, finished it no prob, after it was done though, it loaded up a dm map.
When it did this, I could not get out of the car select menu, I had to force quit unreal to stop it.

- Any chance on getting the locked behindview cam working again?

ProjectX
15th Aug 2004, 01:54 PM
I played the new big air map, jump city, finished it no prob, after it was done though, it loaded up a dm map.
When it did this, I could not get out of the car select menu, I had to force quit unreal to stop it.

You need to set a map play list, that's all.

UltraNew-B
15th Aug 2004, 04:54 PM
Ya, we need to include a default maplist, so noone else has this problem . :)

UltraNew-B
15th Aug 2004, 05:14 PM
In order to gain a more polished, pro look, consistency is important :). I noticed the following maps do not have screenshots and/or descriptions, friday is the deadline:

uwba-avalanche (no ss)

uwkoth-suspension (no desc.)

uwrm-volcano (no ss, no desc.)

uwrc-faerie (no ss, no desc.)
uwrc-hilltop (no ss.)
uwrc-metropolis (no ss.)
uwrc-midnightair (no ss)
uwrc-monsterchallenge (no desc.)
uwrc-motox (no desc.)
uwrc-mountaintown (no desc)
uwrc-sherwood (no ss)
uwrc-vegaseight (no ss)

uwrl-arborea (no ss)

uwrm-volcano (no ss, no desc.)

We also need pics for each gametype, for the menu.

P.S - All vehicles now have correct wheels and the Xcalibur is now ingame at (19200 polys)

:D

jerdaygo
15th Aug 2004, 08:32 PM
In order to gain a more polished, pro look, consistency is important :). I noticed the following maps do not have screenshots and/or descriptions, friday is the deadline:

uwba-avalanche (no ss)

uwkoth-suspension (no desc.)

uwrm-volcano (no ss, no desc.)

uwrc-faerie (no ss, no desc.)
uwrc-hilltop (no ss.)
uwrc-metropolis (no ss.)
uwrc-midnightair (no ss)
uwrc-monsterchallenge (no desc.)
uwrc-motox (no desc.)
uwrc-mountaintown (no desc)
uwrc-sherwood (no ss)
uwrc-vegaseight (no ss)

uwrl-arborea (no ss)

uwrm-volcano (no ss, no desc.)

We also need pics for each gametype, for the menu.

P.S - All vehicles now have correct wheels and the Xcalibur is now ingame at (19200 polys)

:D

hey noob a little fyi, midnight does have an animated preview, i just forgot to build the level before submitting, I had just done a full build before making the preview and didnt realize I needed to do it again, so its there, the next updated it will work, but if you going into Ued and just build and save it will work, but the next version will.

ProjectX
16th Aug 2004, 03:30 AM
WTF??? I made sure, all of my levels have ss. I checked and checked. Maybe you have an old copy of my maps???

If so, grab em off the ftp in my own folder. That's weird cos for the last two uploads I've had descriptions, music and screenshots cos Diego told me to compress em recently cos they were eating file size.

Can your computer not see material sequences? Is that it?

UltraNew-B
16th Aug 2004, 11:38 AM
I can see everyhting fine . :)

Most of the maps simply have the unwheel logo in place of the ss. I dont think its necessary to give them all a material sequence, just a plain old pic would suffice. :D

ProjectX
16th Aug 2004, 12:11 PM
You misunderstand me, the material sequences for all my maps ARE THERE. I'm trying to get to the bottom of why you only see the UnWheel pics. I reckon you must have some of my old maps in there. Make sure you redownload them from my folder on the FTP.

Oh and on the topic of bugs:

Bonus Points are now broken. They don't show up on the hud when you get them, it stays at 0.

Shrimp
16th Aug 2004, 01:29 PM
Fixed

ProjectX
16th Aug 2004, 02:06 PM
Fixed

That was quick :D

Diego1203
16th Aug 2004, 04:40 PM
I just checked them out on mine and I don't see screenshots either, the latest ones that I have are the ones that you submited for the beta drop, I think.

UltraNew-B
16th Aug 2004, 05:06 PM
Project X, there is a folder on the ftp called "completed files for ec / ProjectX", make sure all your newest stuff goes into that. :)

jerdaygo
16th Aug 2004, 08:01 PM
I have previews for all but metro hilltop and sherwood. And thats on the dedicated server that i wipe of all maps before an update, and hilltop and sherwood have a preview that just says UnWheel.

ProjectX
17th Aug 2004, 03:44 AM
That's odd. because the ones I uploaded then had the screenshots on my computer. I'll see if it needs a rebuild, but other than that I can't see any way of fixing it. I'll rebuild all of them and re-upload today, including my newest map too.

Now aren't you lucky.

Shrimp
17th Aug 2004, 04:11 AM
:D

ProjectX
17th Aug 2004, 03:04 PM
I've had some internet downtime today and have been unable to upload it, but rest assured it'll be up there within half an hour.

dub
17th Aug 2004, 06:48 PM
sorry to cut in on your work thread.... but :eek: :clap: :rockon: :crazydance: This is looking mighty tasty again... really anticipating the next version.
Jump cam is really cool !!!!
\o/

ProjectX
19th Aug 2004, 09:24 AM
Right, another bug that's easy to notice (and hopefully easy to fix).

In rabbit the HUD says "Laps" instead of "Points".