PDA

View Full Version : Internet Server Browser workaround


Mix
9th Jun 2004, 10:56 AM
The latest version shipped with a small problem that prevents Duffers servers from showing up in the server browser. To remedy this, find the DuffersUser.ini file in the /Duffers/System folder. Find the '[DuffersGUI.DGMultiplayerBrowserBase]' section and set 'bStandardServersOnly' to FALSE. Start Duffers and servers will now be visible in the Internet server browser. This will be the default setting in future versions.

PingDeth
10th Jun 2004, 12:15 PM
The latest version shipped with a small problem that prevents Duffers servers from showing up in the server browser. To remedy this, find the DuffersUser.ini file in the /Duffers/System folder. Find the '[DuffersGUI.DGMultiplayerBrowserBase]' section and set 'bStandardServersOnly' to FALSE. Start Duffers and servers will now be visible in the Internet server browser. This will be the default setting in future versions.


I found it in the [GUI2K4.UT2k4ServerBrowser] section in the .ini file.

Mix
10th Jun 2004, 12:17 PM
That option exists there as well, but we did not subclass the UT2k4 server browser, so you must find the '[DuffersGUI.DGMultiplayerBrowserBase]' section.

Grakkar
10th Jun 2004, 12:52 PM
That's strange, I don't seem to have a DuffersUser.ini file in my /Duffers/System folder...

Mix
10th Jun 2004, 02:42 PM
do you have a defuser.ini?

Grakkar
11th Jun 2004, 11:30 AM
do you have a defuser.ini?
Yeah, in my /ut2004/system directory.
*edit*
Oh, wait, I've got one in my /duffers/system too. Now why didn't that turn up in the local search I ran...

Mix
11th Jun 2004, 04:18 PM
Duffers.ini and DuffersUser.ini should be automatically generated from default.ini and defuser.ini respectively when you first launch Duffers. If you don't have a DuffersUser.ini file for some reason, you can copy your current user.ini file from UT2004/System and change these entries in [Engine.Input]:

E=Look
H=ToggleHints

also add these sections:

[DuffersGUI.DGServerLoading]
Backgrounds=DuffersInterface.Loading.loadingscreen1
Backgrounds=DuffersInterface.Loading.loadingscreen2
Backgrounds=DuffersInterface.Loading.loadingscreen3

[DuffersGUI.DGMultiplayerBrowserBase]
bStandardServersOnly=false

You'll then have a normal DuffersUser.ini

Grakkar
12th Jun 2004, 04:04 PM
Duffers.ini and DuffersUser.ini should be automatically generated from default.ini and defuser.ini respectively when you first launch Duffers. If you don't have a DuffersUser.ini file for some reason, you can copy your current user.ini file from UT2004/System and change these entries in [Engine.Input]:

E=Look
H=ToggleHints

also add these sections:

[DuffersGUI.DGServerLoading]
Backgrounds=DuffersInterface.Loading.loadingscreen1
Backgrounds=DuffersInterface.Loading.loadingscreen2
Backgrounds=DuffersInterface.Loading.loadingscreen3

[DuffersGUI.DGMultiplayerBrowserBase]
bStandardServersOnly=false

You'll then have a normal DuffersUser.iniYeah, that might work...except I don't seem to have a user.ini in my ut2004/System directory...:(

Could you just...I don't know, e-mail me your DuffersUser.ini or something?

Mix
13th Jun 2004, 12:08 AM
That would explain why you don't have a DuffersUser.ini... It's attached.

Grakkar
5th Jul 2004, 12:42 PM
That would explain why you don't have a DuffersUser.ini... It's attached.
Well, that didn't work, but I found a DuffersUser.ini file in my /home/user/.ut2004/duffers/system directory. I didn't even know about the .ut2004 directory. And that would explain why your fix didnt work. And wow...there's one server!!!! And there's no-one on it!!!!