PDA

View Full Version : 2DT ported to UT2004


eggshen
4th Jun 2004, 04:55 AM
I saw the call for modders post on beyondunreal and was curious about what the mod looks like. I took the existing code and ported to 2k4. It's available here at:

http://s87030170.onlinehome.us/ut/

Unzip the .u* and .int files to system/. I only tested ctf and dm with bots so I'm not sure about other types. I didn't really do much except making it run under 2k4.

I hope this can generate more interest for the project.

FreakinMeany
4th Jun 2004, 02:04 PM
/me cheers

Wow! Awesome eggshen. This is a great first step.

Make sure you also put the .UCL file in the system folder as well.

[edit]

Just checked this out:

Not sure if this is a a 2Dmap bug or just due to the nature of the port, but the game isn't in 2D (side-scrolling) mode when you load up a 2D gametype.

I'm assuming that it wasn't for you either, eggshen. Correct?

striderdm1
4th Jun 2004, 03:44 PM
S-U-P-E-R-B !!!!!!!!! :D Nice one Eggshen :D :D :D :D :D :D :D

eggshen
4th Jun 2004, 09:03 PM
I tried it with the 3rd party maps (specifically 2ddm-pyramid-beta4, 2dctf-pharaoh) listed on one of the threads here on the forum and it works for me. I tried the regular 3D maps and they wouldn't work. I assumed they weren't working in ut2k3. Is that a wrong assumption?

Screenshot here, just to check that what I'm seeing here is a working 2DT:

2ddm-pyramid-beta4:
http://mars.walagata.com/w/eggshen/Shot00027.jpg
http://mars.walagata.com/w/eggshen/Shot00028.jpg

2dctf-pharaoh:
http://mars.walagata.com/w/eggshen/Shot00034.jpg http://mars.walagata.com/w/eggshen/Shot00035.jpg


/me cheers

Wow! Awesome eggshen. This is a great first step.

Make sure you also put the .UCL file in the system folder as well.

[edit]

Just checked this out:

Not sure if this is a a 2Dmap bug or just due to the nature of the port, but the game isn't in 2D (side-scrolling) mode when you load up a 2D gametype.

I'm assuming that it wasn't for you either, eggshen. Correct?

master_newbie
5th Jun 2004, 01:45 AM
:clap:

yes you cant play it in the ut2004 DM/CTF/etc. maps, you have to play in 2DDM/2DCTF/2Detc. maps

nice to see the 2d mod again :fluffle:

FreakinMeany
5th Jun 2004, 02:07 PM
Weird... I'll give it another go. Maybe it was a fluke or maybe it's because I'm running the Mac version of UT2004. Will let you know.

[edit]

Well, I'm stupid :)

I guess I didn't copy all the files over for some reason. Anyway, it works great (and the bots seem smarter even!).

Thanks. I'll be adding this version to the official site (http://www.2dtournament.com/) in just a minute.

[edit]

It's mirrored and up. Thanks again Eggshen!

O.S.T
5th Jun 2004, 05:20 PM
w00t!! \o/

when I buy ut2004 this summer I'll have fun(and if I'm bored there could be a new map,but just when I'm bored)

ssj4
7th Jun 2004, 11:56 AM
toh, great stuff egg!! now i gotta get ut2004

shintree
5th Oct 2004, 12:18 PM
umm, stupid question, but how do i get this to work with 2k4? i had it working in 2k3 no prob, but now I select the gametype and cannot find the 2ddm maps i've dl'ed. any input would be appreciated. thanks

FreakinMeany
6th Oct 2004, 03:48 AM
Did you grab the 2k4 version of the mod first? Very important :) Also make sure you've copied the maps into the ut2k4 maps directory.

You can grab the 2k4 version of the mod here:

http://www.2dtournament.com/

shintree
6th Oct 2004, 03:56 PM
yup, got the 2k4 version, but still no love. it loads the maps but in regular FPS mode. do i move all of the .u files? even the ones name k0lpa2d not k0lpa2d2k4? thanks again!!! Just tried again. moved the files named k0lpa_2d2k4 to the system dir. the maps show and load, but i'm still in FPS mode. tried with just the files name k0lpa_2d and nothing at all. the maps don't even show. I'm running the latest patch could that be a problem? I got it finally. copied all of the files and chose the proper gametype. I have the gametypes showing up twice in my list now though. is there any way to clear that up?

FreakinMeany
7th Oct 2004, 04:13 AM
Hmm... I had the same thing happen to me and can't remember what I did to fix it. Look in your system folder and see if you've got .UCL files that correspond to any of the 2D mod files - removing these may fix the problem as UT2004 will regenerate a new set for you...

Actually, you might want to move them onto your desktop before deleting them just in case something breaks.

Glad you got it working.

FrozenCow
9th Oct 2004, 09:05 AM
:( I've noticed that 2D Tournament mod doesn't work anymore with UT2004 when the new patch (version 3323). The problem is in the PlayerTick function, this crash also happened to me with USkaarj :( (Is it me?)