PDA

View Full Version : I have problems hosting a FHI game


tgranholm
20th May 2004, 12:54 PM
I installed the mod to UT2004\FHIMod like it was supposed to and removed the old one with the .bat file. I also patched the game.
Instant Action game mode works without problems, but when I try to host a game after I've selected a map and mutators and other stuff, and after I click Listen the game starts to load (goes to the loading screen) then closes and a new window opens saying:

Critical Error

UT2004 Build UT2004_Patch_[2004-05-10_17.18]

OS: Windows XP 5.1 (Build: 2600)
CPU: AuthenticAMD PentiumPro-class processor @ 1200 MHz with 511MB RAM
Video: Hercules 3D Prophet 8500 Series (6414)

Failed to load 'UT2K4Secure': Can't find file 'UT2K4Secure'

History: UObject::SafeLoadError <- UObject::GetPackageLinker <- UGameEngine::BuildServerMasterMap <- ULevel::Listen <- Listen <- UGameEngine::LoadMap <- LocalMapURL <- UGameEngine::Browse <- ClientTravel <- UGameEngine::Tick <- Level Arctic Dam <- UpdateWorld <- MainLoop <- FMallocWindows::Free <- FMallocWindows::Realloc <- 676F4C57 0 FArray <- FArray::Realloc <- 0*2 <- FMallocWindows::Free

I tried searching the file 'UT2K4Secure' but couldn't find it so I'm a bit lost. What should I do to get it work?

Parser
20th May 2004, 01:56 PM
UT2k4Secure comes with the 3204 Win32 patch. Why you don't have this is a mystery to me, unless you don't have the patch. :con:

Lemme know if that's the case. If not, I'll upload the file.

shockmonkey
20th May 2004, 08:39 PM
I too have the same problem with the Can't find file 'UT2K4Secure' when I try to host a game of the new fraghouse invasion. I do have the 3204 patch installed, but I continue to get the errors. Ive installed on 3 different computers and its the same on all of them. Is there a way I can install the ut2k4 secure seperately to correct the problem? Thanks.
BTW great job on fraghouse invasion. Its the most popular game mode at my lan parties.

Parser
21st May 2004, 01:57 AM
Ok, apparently the public patch didn't come with UT2k4Secure (but the beta ones did), so please try downloading this: www.asup61.dsl.pipex.com/ut2k4secure.zip and stick it in your UT2004/System/ folder.

If that fixes the problem, please let me know. :)

tgranholm
21st May 2004, 05:07 AM
Yep, that solved the problem, thanks.
By the way, what does the UT2K4Secure do? Is it somehow important to the game or something? And if so why did they leave it out of the public patch? Just wondering...

Parser
21st May 2004, 10:17 AM
It's described as an "interim security patch" in the mutator menu. What does it fix? No idea... :P

Dark_Dust
22nd May 2004, 05:03 AM
The same error: 'Failed to load UT2K4Secure: cant find file UT2K4Secure' also appears when you try to run UnrealEd for FHI2K4 from the FHIMod folder.

Downloading and installing the file from the zip posted above solves the problem ..just as the "run server problem".. :)

Parser
22nd May 2004, 06:13 AM
Yeah, that's because UT2k4Secure automatically got put in my EditPackages (which UED calls) by the patch update. :hmm:

Sorry about that, if there's a future update I'll make sure to take it out!

Dark_Dust
22nd May 2004, 09:38 AM
Ah.. np parser.. i noticed later on the same thing.

For the ones running into the same issue (unrealedFHI2K4).. if your not planning to run a server, then you dont need to download the ut2k4secure package. Well, its very small... but i always say..dont get things you dont need.. :rolleyes:

Just browse to FHIMod folder within UT2004 and open up FHIMod.ini, next scroll down till you come to '[Editor.EditorEngine]' look for 'EditPackages=UT2K4Secure' and delete that line. Save it and it should be all ok..
Whatever you do, delete that line or get the package, either way will solve the issue. :)

Blueberry
2nd Jun 2004, 03:02 PM
Our clan uses UTSecure for clan matches since it is required by most leagues.
UTsecure is an anti cheat program. The 3204 patch may have UTSecure integrated.

Rubinrox
10th Jun 2012, 11:53 PM
Please,I need FHImod folder for postal 2 when i open postal 2,It shows "Failed to enter Entry: Can't find file 'Entry'

History: UGameEngine::Init <- InitEngine"I want to play that game :wtf: If you give pages like this"www.asup61.dsl.pipex.com/ut2k4secure.zip"Please Don't give me like this Because It shows "404 page not found"