PDA

View Full Version : Updates on UT2004 version


Shrimp
4th May 2004, 01:54 AM
I just thought I'd make this thread to keep you up-to-date with my progress of converting UnWheel to UT2004 :D

Last night I got started, and after a load of changes and fixes (since Epic have changed large amounts of vehicle and player code), I FINALLY got it to actually compile without errors or warnings.

In the process, I had to remove the custom fonts from the UnWheel GUI, as UT2004 no longer lets me use my own fonts... Also, the GUI is completely messed up, the transparent effect is gone and somehow the vehicle preview is behind the rest of the interface.

Anyway after a few more hours of trying to get a gametype to show in the list and getting a vehicle to spawn, I've found that the vehicle refuses to respond to any input, and there is no resistance or friction, so the vehicle just rolls backwards and forwards endlessly... The Bulldog is also completely broken in the same way, so I can't get any ideas from that either :(

Also, in order for the gametypes to work, we need to remove the dash "-" from the map names, so "UW-RM-Clearing" needs to become "UWRM-Clearing", etc. It should just be a case of renaming existing maps, however if some maps are dependent on other maps, they will be broken until the references are fixed.


Another update tomorrow, with a drivable vehicle I hope :D

stevenhorton
4th May 2004, 07:20 AM
Cheers Shrimp:)

ProjectX
4th May 2004, 10:22 AM
Cheers Shrimp:)

dude, why did epic make their changes without rendering it backward compatible with the KVehicle code anyway? They already had KVehicle, then they added SVehicle, but why dd they remove the functionality of KVehicle! It's not like KVehcile was taking up much space.

GRAF1K
5th May 2004, 11:54 AM
dude, why did epic make their changes without rendering it backward compatible with the KVehicle code anyway? They already had KVehicle, then they added SVehicle, but why dd they remove the functionality of KVehicle! It's not like KVehcile was taking up much space.

They want to force people to use the new, updated vehicle code. Besides, the UT2003 version has some netplay issues with vehicles anyhow.

AllowVehicles in enabled in the gametypes' defaultproperties, correct Shrimp? Look at vCTF if it isn't.

(And I for one greatly appreciate the update :))

Shrimp
5th May 2004, 12:25 PM
OK, I have drivable vehicles and mostly fixed physics, though all the vehicles are going a lot faster than they should be, I'm going to need to re-factor all their torque properties to get them working properly again... :(

Also very busy on the GUI, which I've thrown away and am making a standard UT2004-style one from scratch.

Tez
5th May 2004, 07:01 PM
I am extremely glad to see this update being worked on. My two favorite types of games are racing games, and Unreal. I can't wait to play this! Thanks for all your hard work, Shrimp. :D :D :D

GRAF1K
6th May 2004, 01:47 PM
Are you using the new vehicle code or did you beat the old vehicle code into submission?

(An interesting thing to note, Shrimp, is that both the Phoenix and the bulldog are not player-controlled, and both have the same issues with turning, etc.)

TriggerHappy101
7th May 2004, 04:40 PM
Im glad your getting it to work. :) Cant wait. :D

UltraNew-B
12th May 2004, 12:51 PM
I have experience working with S-Vehicles, getting them ready in max and importing into ued3, and playing ingame. I can help you out shrimp if your in need. :)