PDA

View Full Version : UT2004 Mapvoter V-CTF


eXo2004
29th Mar 2004, 10:48 AM
Ok heres another one...

I and others it seems have attempted to setup the VCTF gametype in the Mapvoter thru webadmin. We have also made sure that the gametype has the proper maps listed in the active maps cycle. But when you go into the game and pull up the Mapvoter and then choose the new voteable gametype, none of the VCTF maps are listed.

You can however tell webadmin to switch to the VCTF gametype and a VCTF map just fine then go in and play the map without any problems. It seems you just cant get the Mapvoter to see or display any of the VCTF maps.

Nihilist
29th Mar 2004, 12:16 PM
your problem is likely to be this section

[xVoting.DefaultMapListLoader]
bUseMapList=False
MapNamePrefixes=DM,DOM,CTF,BR,AS,ONS,VCTF

make sure you have VCTF as a known prefix


just helped fix this for somone on the atari forums , and this was his issue

eXo2004
29th Mar 2004, 01:28 PM
ummm it looks as if i dont have that heading in my ini file. Do you know what the full list of entries are suppose to be within that header so i can add it myself to the ini file?

Thanks

Nihilist
29th Mar 2004, 02:45 PM
ummm it looks as if i dont have that heading in my ini file. Do you know what the full list of entries are suppose to be within that header so i can add it myself to the ini file?

Thanks


just throw up the entire thing i posted earlier should be suffice

eXo2004
29th Mar 2004, 04:47 PM
just throw up the entire thing i posted earlier should be suffice

Ok well i did that and i still have no luck. Here is what i have for settings in regards to VCTF in my ini file.

[xVoting.xVotingHandler]
VoteTimeLimit=70
ScoreBoardDelay=5
bAutoOpen=True
MidGameVotePercent=50
bScoreMode=False
bAccumulationMode=False
bEliminationMode=False
MinMapCount=2
MapVoteHistoryType=xVoting.MapVoteHistory_INI
RepeatLimit=4
DefaultGameConfig=0
bDefaultToCurrentGameType=True
bMapVote=True
bKickVote=False
bMatchSetup=False
KickPercent=51
bAnonymousKicking=True
MapListLoaderType=xVoting.DefaultMapListLoader
ServerNumber=1
CurrentGameConfig=11
GameConfig=(GameClass="XGame.xVehicleCTFGame",Prefix="VCTF",Acronym="VCTF",GameName="VCTF",Mutators=,Options=)

-------------------------

[XGame.xVehicleCTFGame]
bAllowNonTeamChat=False
FriendlyFireScale=0.000000
NetWait=5
bForceRespawn=False
bAdjustSkill=False
bAllowTaunts=True
bAllowTrans=False
SpawnProtectionTime=2.000000
LateEntryLives=1
LoginMenuClass=GUI2K4.UT2K4PlayerLoginMenu
bAllowPrivateChat=True
bWeaponStay=True
bAllowWeaponThrowing=True
ResetTimeDelay=0
GoalScore=3
MaxLives=0
TimeLimit=20

---------------------------

[XInterface.MapListVehicleCTF]
MapNum=0
Maps=VCTF-zX-Gallery

Now whats interesting is everytime i go and add the following lines to my ini file, ut2004 removes part of it and adds the entries to the [xVoting.xVotingHandler] section instead. Not sure why or if it suppose to but it does.

[xVoting.DefaultMapListLoader]
bUseMapList=True
MapNamePrefixes=DM,DOM,CTF,BR,AS,ONS,INV,VCTF

so you end up with the [xVoting.xVotingHandler] section looking like this....

[xVoting.xVotingHandler]
VoteTimeLimit=70
ScoreBoardDelay=5
bAutoOpen=True
MidGameVotePercent=50
bScoreMode=False
bAccumulationMode=False
bEliminationMode=False
MinMapCount=2
MapVoteHistoryType=xVoting.MapVoteHistory_INI
RepeatLimit=4
DefaultGameConfig=0
bDefaultToCurrentGameType=True
bMapVote=True
bKickVote=False
bMatchSetup=False
KickPercent=51
bAnonymousKicking=True
MapListLoaderType=xVoting.DefaultMapListLoader
ServerNumber=1
CurrentGameConfig=11
GameConfig=(GameClass="XGame.xVehicleCTFGame",Prefix="VCTF",Acronym="VCTF",GameName="VCTF",Mutators=,Options=)
bUseMapList=True
MapNamePrefixes=DM,DOM,CTF,BR,AS,ONS,INV,VCTF

any thoughts?

Nihilist
29th Mar 2004, 05:20 PM
that interesting try the following

delete this part
bUseMapList=True
MapNamePrefixes=DM,DOM,CTF,BR,AS,ONS,INV,VCTF
from [xVoting.xVotingHandler]

then add this below it, leave usemaplist set to false

[xVoting.DefaultMapListLoader]
bUseMapList=False
MapNamePrefixes=DM,DOM,CTF,BR,AS,ONS,VCTF,

eXo2004
29th Mar 2004, 07:00 PM
that interesting try the following

delete this part
bUseMapList=True
MapNamePrefixes=DM,DOM,CTF,BR,AS,ONS,INV,VCTF
from [xVoting.xVotingHandler]

then add this below it, leave usemaplist set to false

[xVoting.DefaultMapListLoader]
bUseMapList=False
MapNamePrefixes=DM,DOM,CTF,BR,AS,ONS,VCTF,

Well that seem to work. I noticed this time that ut2004 didnt move the entries as it had last time when it was set to true and now it lists the VTCF maps in the Mapvoter window.

Do you know what this line is actauly telling the game 'bUseMapList=False' i mean which map list is it being told to use or not use, which ever the case may be?

Thanks again, i really apreciate the help.
eXo

BDB
29th Mar 2004, 09:41 PM
If you set bUserMapList to True then you can specify specific map lists to load the
map names from. If you do not specifiy any maplists then it will load the mapnames
from the default maplists set in the game type. Therefore; setting bUseMapList=True
with no other setting will work fine.

If you want to specify specific maps lists then use this:

Example:
[xVoting.DefaultMapListLoader]
bUseMapList=True
MapListTypeList=MapListVehicleCTF
MapListTypeList=MapListCaptureTheFlag


Possible MapListTypeList settings are:
ONSMapListOnslaught
MapListVehicleCTF
MapListTeamDeathMatch
MapListSkaarjInvasion
MapListMutant
MapListLastManStanding
MapListDoubleDomination
MapListDeathMatch
MapListCaptureTheFlag
MapListBombingRun
ASMapList