PDA

View Full Version : Will someone check this out for me


Bhaal26
27th Mar 2004, 09:11 PM
I'm making my first map ever. I'm trying to put the weapon spawns on the map. Read a guide but when I play the map they don't show up at all. either does the ammo. what am I doing wrong.

MustaphaMond
29th Mar 2004, 11:40 AM
Hi, I'm also new to this mapping thing. I'm not sure I can solve your problem but I did have a similar issue in my current map. I was trying to put a shield charger on a box that I'd put on the ground. If I had the charger physically positioned to be sitting on the box the sheild would never spawn. But then I positioned it just above the floor (embedded in the box with an adjusted spawn height), and now it spawns. Also, make sure that you have bDelayedSpawn=False and remember that some items take longer than others to spawn (ie. redeemers and sheids). Hope that helped.

I'm still trying to find which setting affects the respawn time of items. Anyone out there know?

Kyouryuu
29th Mar 2004, 12:32 PM
Have you tried taking the long way there and going out to the title screen, then starting the map like you normally would? Sometimes when I would start my map, the weapons wouldn't be there either. I'm not sure why it is, but sometimes when you try to test the map, launching it from UnrealEd, you wind up in a game mode like Last Man Standing or Mutant that you never set (but apparently the game thinks you have).

MustaphaMond has the rest of it right. Make sure that bDelayedSpawn = False. This is especially true of high-value spawners like the Super Shield and the UDamage Amplifier, which default to a setting of bDelayedSpawn = True.

Also, it's worth noting that your map does not have any path nodes. While it may not be the source of the problem, having paths may help identify what's wrong. You need path nodes in order for the bots to navigate the map and fetch the items they need to kill you. See the Wiki or UDN for more details.

JonAzz
29th Mar 2004, 02:15 PM
did you guys do build all? sometimes this fixes it...

Go&nd
29th Mar 2004, 08:23 PM
Kyouryuu got it right. The default game type is set to Last Man Standing. To change it, just go to:

View>Level Properties

Expand LevelInfo, then find DefaultGametype and change it to:

xGame.xDeathmatch

Hit save, then hit Play Level and your weapons will be there (no, you don't even need to rebuild after you change the setting).

I checked it out and it worked fine as soon as I changed the setting. :tup:

Hope that helps. Good luck with the map. :)