PDA

View Full Version : Skinnilicious Issue


BabyEater
26th Mar 2004, 11:06 PM
Hey, I've got myself an issue. I'm not too keen on the punk flamer skins that came with 2k4, so I thought I'd make use of the models and reskin them. Problem is, I'm not keen on spikes either. I think they're played out. But I noticed that if I left the textures transparent, they wouldn't appear in UPaint. So I did so. I then made the entire skin until I liked it.

Then I fired her up in 2k4 and boom, not only are there spikes, but there are spikes that didn't show up on the original skin (Garrett). I knew those spikes were there from when I was skinning, but they should be transparent.

Upaint:
http://www.twignificant.com/files/ut/skin/wreckingball.jpg

Game:
http://www.twignificant.com/files/ut/skin/wreckingball_spikes.jpg


Anybody have any suggestions on how to get rid of these without modeling (because I don't know how :D ) ? Or if it can be solved just by double-checking the transparency, then does anyone know how I can get a wire-mesh image to place over the image in photoshop?


***

BabyEater
28th Mar 2004, 05:59 PM
aw, c'mon... somebody? i've posted all over about this and no one seems to have anything to say. not even the rote stuff like alpha channels and whatnot. ;D

shadow_dragon
28th Mar 2004, 06:18 PM
I think i did transparency on a skin ebfore but it's a hassle! Something to do with using an absolute black and masking it or making a .gif with transparency and importing it with maksing or alpha channels! I can't quite remember! I'd advise looking at another skin texture which you know has transparency on it! i think some of the hellion ones do!

it's awkward though i'm afraid i'll have a look, see if i can remember or find anything!

shadow_dragon
28th Mar 2004, 06:23 PM
Try this!
http://planetunreal.com/identitycrisis/tutorials/ut-skinning-tutorials/masking-textures/index.shtml
Might help! If not sometihng on that site might!

BabyEater
28th Mar 2004, 10:33 PM
Thanks a lot, shadow dragon. I got it cleared up by making the alpha channel in Photoshop, but the trick was saving it as a 32-bit tga. I guess I hadn't tried it because Photoshop doesn't give you the option to save the alpha channel with the tga, but I guess it does it automatically.

Yeah, I've seen a lot of people with this issue involving the female models, but I never see a definitive answer. lol

For anyone looking on how to do this, you not only need the alpha channel, but you need to save it as a 32-bit *.tga and you need to import it directly into UEd, not Upaint. Also, you need to mark "alpha" when you import it. You'll see the transparent parts as transparent in UEd.

All those things have to be done together. :D

Thanks, Shadow.
T.

siriusmindfrag
3rd Apr 2004, 05:51 PM
LOL Well I hope I can figure all this out. I need a skinprofessor.

aliasNIGMA
3rd Apr 2004, 07:01 PM
Easy Look Only use UPAINT to preview your model.

Heres the fix:

First Several Possbile Problem Areas:

Textures Not Imported with Alpha Texture Enabled
-or-
Shaders If Used havent got opacity texture set to a texture with proper alpha channel

Ill assume you arent using shaders at this point.

First have UnrealED3 open and pantsop or photoshop open (I use Pantshop pro7)

The Idea is this, make your skin texture with the transparancy image stored in the alpha channel.

I find its best to save the texture as a PSP file or the equiviliant native Photoshop image to save the layers for a master copy.
Dont worry if you dont use layers.

When you need to import the image save it as a TGA file.

Continuing on what was previously mentioned, the alpha channel is a greyscale image that accompanies the main texture image. PNG and TGA files support this property.

By placing absolute black in the alpha channel the coordinates cooresponding to the texture will show as invisible, shades of grey are varying levels of transparant.


Judging from the problems youve been having... You probably havent setup your texture properly in the editor, and when you manage to do so... you might find you need to make a few extra spots on the textre transparant (which happens to me often enough)


Dont use Upaint to create your texture package do it manually with the UnrealED Texture browser.

Yes that reminds me... the reason you cant get transparantcy is because you are using UPAINT to load your textures into UTX packages.

So the solution -> Learn to use UnrealED texture browser.

(hint open your existing UTX files to see how things are setup and use the texture browser to manually replace the textures.)

Upaints definatley what your problem is.