PDA

View Full Version : Building lighting problems


jeeves
12th Mar 2004, 02:53 PM
Hi
When i try to build the lighting the engine closes and displays the following message

OS: Windows XP 5.1 (Build: 2600)
CPU: GenuineIntel Unknown processor @ 2407 MHz with 255MB RAM
Video: Mobility Radeon (6015)

General protection fault!

History: FPoly::SplitWithPlane <- FPoly::SplitWithNode <- FEditorVisibility::FilterThroughSubtree <- FEditorVisibility::FilterThroughSubtree <- FEditorVisibility::FilterThroughSubtree <- FEditorVisibility::MakePortalsClip <- FEditorVisibility::MakePortals <- FEditorVisibility::TestVisibility <- UEditorEngine::TestVisibility <- UEditorEngine::shadowIlluminateBsp <- UEditorEngine::Exec_Light <- UEditorEngine::Exec <- (LIGHT APPLY) <- UUnrealEdEngine::Exec <- WPageOptions::BuildLighting <- WEditorFrame::OnCommand <- WWindow::WndProc <- WWindow::StaticProc <- MessagePump <- MainLoop

I only have about 6 lights and have tried it without any lights and still have the same problem. When i got to build all it exits during the lighting phase. The geometry and paths build fine without any problems when done separately its just the lighting.

Could it be a hardware problem? Can anyone help?

Thanks

ttl
12th Mar 2004, 11:34 PM
It looks like the problem is with your BSP, did you add any strange brushes?

jeeves
13th Mar 2004, 02:20 PM
I don't think so. All I have is additive and subtractive brushes and static meshes. I converted some of my brushes for objects such as chairs to static meshes by right clicking on the object and then going to convert-->static mesh, could this be the problem?

jeeves
14th Mar 2004, 08:45 AM
I managed to build the lighting but now the geometry doesnt build. It does three quarters of illumination occluding and then the engine just closes and im returned to the desktop without any errors or anything.

Please help

oki
21st Mar 2006, 12:49 AM
i had a big map go balls-up n found it was a zone i created earlier had miraculously/typically doubled in size and was mixed up with another zone.
used the zone view to find the problem,,dunno if its any help 2 u but took my noob ass a while to figure it out