PDA

View Full Version : Mapvoting causes server crash!


Shadowhaxor
19th Jan 2004, 05:34 PM
I just started using the mapvote mutator to run my invasion server. Howeve, when I choose a map or when a map is choosen, its simply crashes the server, and then when it restarts you have to goto the web admin and choose the mutators. I run the invasion game with the excessive weapon mod.

Every time! Also, I have to manually start the mapvote mod, even though I have it set in my command line and server.ini. Is there a way to accomplish this?

[MapVote400b11.MapVote]
VoteTimeLimit=35
ScoreBoardDelay=10
bAutoOpen=True
MidGameVotePercent=50
MinMapCount=10
RepeatLimit=4
bScoreMode=False
bAccumulationMode=False
bEliminationMode=False
DefaultGameConfig=0
bDefaultToCurrentGameType=True
bKickVote=False
KickPercent=51
bRestartWithLastMap=False
bAnonymousKicking=False
MapVoteHistoryType=MapVote400b11.MapVoteHistory1
MapListLoaderType=MapVote400b11.DefaultMapListLoader
GameConfig=(GameClass="Skaarjpack.Invasion",Prefix="DM,CTF,BR",Acronym="INV",GameName="UBG'S Excessive Invasion",Mutators="MapVote400b11.MapVote,XGame.MutQuadJump"ExcessiveV2.Excessive")

[MapVote400b11.DefaultMapListLoader]
bUseMapList=False
MapNamePrefixes=DM,CTF,DOM,BR,INV
MapListTypeList=SkaarjPack.MaplistSkaarjInvasion


Thanks.

BDB
20th Jan 2004, 12:36 PM
Take a look at the server's log file to see why it is crashing.

Also, If you have mapvote loaded correctly in the command line you shouldn't have
to start it manually. Post your start up script with the command line so we can check
it.

Shadowhaxor
20th Jan 2004, 03:10 PM
@echo off
:10
c:\ut2003dedicatedsrvr\system\ucc.exe server DM-Banished][?Game=SkaarjPack.Invasion?GameSpeed=1?WeaponStay=True?Translocator=True?FriendlyFireScale=0?GoalScor e=0?TimeLimit=0?MaxLives=1?AllowThrowing=True?ForceRespawn=False?Mutator=XGame.MutQuadJump,XGame.Mut Regen?GameStats=True?BalanceTeams=False?MinPlayers=1?MaxPlayers=16?MaxSpectators=2?AdminName=user?Ad minPassword=pass?GamePassword=?Mutator=ExcessiveV2.Excessive?Mutator=MapVote400b11.MapVote?PlayersMu stBeReady=False?AllowBehindview=True?difficulty=2 INI=invpub.ini port=7977 -log=invpub.log
copy c:\ut2003dedicatedsrvr\system\invpub.log c:\ut2003dedicatedsrvr\system\invpubcrash.log
goto 10



Take a look at the server's log file to see why it is crashing.

Also, If you have mapvote loaded correctly in the command line you shouldn't have
to start it manually. Post your start up script with the command line so we can check
it.

Shadowhaxor
20th Jan 2004, 05:03 PM
Nevermind, I should have seen my error.

Instead of this:

Mutator=XGame.MutQuadJump,XGame.MutRegen,ExcessiveV2.Excessive,MapVote400b11.MapVote

&

I had this:
Mutator=XGame.MutQuadJump,XGame.MutRegen?Mutator=ExcessiveV2.Excessive?Mutator=MapVote400b11.MapVote

Doh! :lol:

@echo off
:10
c:\ut2003dedicatedsrvr\system\ucc.exe server DM-Banished][?Game=SkaarjPack.Invasion?GameSpeed=1?WeaponStay=True?Translocator=True?FriendlyFireScale=0?GoalScor e=0?TimeLimit=0?MaxLives=1?AllowThrowing=True?ForceRespawn=False?Mutator=XGame.MutQuadJump,XGame.Mut Regen?GameStats=True?BalanceTeams=False?MinPlayers=1?MaxPlayers=16?MaxSpectators=2?AdminName=user?Ad minPassword=pass?GamePassword=?Mutator=ExcessiveV2.Excessive?Mutator=MapVote400b11.MapVote?PlayersMu stBeReady=False?AllowBehindview=True?difficulty=2 INI=invpub.ini port=7977 -log=invpub.log
copy c:\ut2003dedicatedsrvr\system\invpub.log c:\ut2003dedicatedsrvr\system\invpubcrash.log
goto 10

BDB
20th Jan 2004, 07:14 PM
So, did fixing that solve the server crash problem also ?

Shadowhaxor
20th Jan 2004, 07:22 PM
Yes, it did. Don't know why.