PDA

View Full Version : Playing character animations from a ukx file


mjcramer
5th Jan 2004, 06:01 PM
Okay, this has got to be an easy one, there's something really stupid that I'm missing...

I'm trying to specify a set of movement animations (among other things) from a character animation file. Now, I've looked in the xPawn class and it seems that all they do is load the appropriate file via


defaultproperties
{
Mesh=mesh'CharacterAnims.CharacterMesh'
MoveAnims(0)=NameOfAnimation
etc..
}


and I assume that that name is available by virture of


#exec OBJ LOAD FILE=CharacterAnims.ukx


Yet when I run my game and it engine tries to play the animation (like while the pawn is walking) it says:

Log: PlayAnim: Sequence 'NameOfAnimation' not found for mesh 'CharacterMesh'. I've opened CharacterAnims.ukx in ued and I assure you that it is there. What gives?

[SAS]Solid Snake
5th Jan 2004, 07:26 PM
You can't just use any animation for a mesh, the animation must also belong to the mesh. For example, some of the animations that were done for some other meshes (take the Gorge model for the intro) can't just be applied onto the player models. Thus not only do you have to take care on what animations you choose but also what mesh you wish to apply onto the animation.

mjcramer
6th Jan 2004, 02:37 AM
Solid Snake']You can't just use any animation for a mesh...

Absolutely right, and I forgot to mention that it was for the correct mesh (I'm a code guy, not an art guy ;). Anyway it turns out the problem was with a corrupted art file. I had the animations rebuilt and now they work. Thanks for your response...