PDA

View Full Version : NTLDR missing


Derelan
5th Sep 2003, 11:26 PM
What a crappy day...

So i got bored of XP, i had nothing better to do, i downloaded Mandrake Linux and installed away. Whoopee, I remembered how amazingly tedious it is to install programs in linux, so i decided to boot back to windows XP. Much to my suprise, windows will not boot, as it either reboots or hangs after loading "mup.sys". So i get pissed off, do some research on this "mup.sys" problem, it's apparently common to disconnect your USB and everything works again. Well, my USB doesnt disconnect, its built-in, and i already have it disabled in the BIOS.

So, stupid me, i try to use the "resolution of all problems" and I boot the Windows XP installation disk and use the recovery console. I don't quite recall if this was ever successful, but i use the "fixboot" and "fixmbr" commands without even thinking of the harmful effects on my windows partition. Hurray, I no longer have my dual-boot menu for selecting windows/linux, all i have is a message that says "NTLDR missing".

So i boot my mandrake linux CD, i type in "rescue", i use the "rebuild dual boot menu" command. I can at least boot into linux now and post this message, but when i try to boot Windows i still get the classic "NTLDR missing" error. Oh, by the way, i have tried copying "cd:\i386\ntldr" to my root drive, no luck.

So, i have searched on google, and the NTLDR message is one of those "you're universally ****ed" messages, meaning anyone who screwed up their system can get it, so i basically would have to try 100's of different ghetto fixes to find one that works.

But now, i am tired, and i am happy that i at least have an operating system in which to boot to. I shall finish this in the morning, and hopefully i shall take a step forwards instead of backwards.

LifesBane[4C]
5th Sep 2003, 11:40 PM
I just browsed quickly on google groups, so you probably saw this... but just in case you overlooked the groups section:

"But you must also restore NTLDR, NTDETECT.COM, BOOT.INI and BOOTSECT.DOS
to the root of C in order for NTLDR to work"

Are all those files there? Or can you even check, hehe. Don't know about dual operating system stuff and if you can see other OS files with Linux.

2_SeeK_U
6th Sep 2003, 02:43 AM
do you get this message on boot up?? So does this happen before your able to use dos?
I would say so but l'm just making sure.

What l would try is using another XP machine, copy its file structure (of course you have to sort out the system file to your personal, unneeded files). I did this when l had trouble booting up in 98SE when l was dual booting using System commander 7, I just went into xp as normal, logged onto my other 98SE computer and just fiddled.... eventually l got it to work. My problem was a simple, corrupt file error. One of the virtual memory files were corrupt leaving me high and dry.

Anyway good luck, pls tell us how you fixxed this cos it might help me some time at work.

Derelan
6th Sep 2003, 09:36 AM
i get the NTLDR error AFTER i get my dual-boot menu, meaning only if i select the windows operating system to boot. This means i know it is not a Master Boot Record problem, it is only a partition boot record problem.

Bane, no i did not check the usenet groups, silly me :) , I cannot check to see if those files are there, but i can replace them using the recovery console, so i shall do that.

My biggest problem is that i cannot re-install windows. According to linux, all my partitions are good and fine, ie: my windows partition is still NTFS and still drive letter C. However, according to windows setup, drive letter C is un-partitioned and so it would like to format it. Not happening, i shall replace those files instead.

Derelan
6th Sep 2003, 01:03 PM
i was able to mount both NTFS partitions (the one that won't boot, and a secondary one), and linux was able to read the secondary one. It claims that the ntfs boot partition is empty. The windows CD claims it is unformatted. CHKDSK claims it is unrecoverable. Western Digital DataLifeguard claims it is error free.

I have a windows XP boot-disk designed to be a temporary fix to the NTLDR problem, and it sortof works. My ntfs boot partition boots XP, asks me if i want safemode/last config etc., but stops during load, claiming that "hal.dll" is missing. I miss the days of Windows 98 in which you can choose which dlls to load.

Hadmar
6th Sep 2003, 01:09 PM
Maybe this helps: http://www.kellys-korner-xp.com/xp_haldll_missing.htm

Derelan
6th Sep 2003, 01:37 PM
i've been directed there on other forums many times as well, thanks though hadmar.

2_SeeK_U
8th Sep 2003, 04:59 AM
My xp partion shows that the hal.dll is in the folder system32. most likely its corrupt or just missing. Try replacing it with one of your xp cd or here is mine, just take of the .zip...

Derelan
8th Sep 2003, 05:42 PM
i appreciate it SeeK, but i also just found out that i was right when the hal.dll/NTLDR is an error message that means "you are ****ed". Basically, if there is no boot sector at all (ie, on a floppy), you will get the "NTLDR" message (no i dont have a floppy in my drive). If you use a boot disk, it simply looks for a "hal.dll" first, and it will stop at that file, first.

I have restored the partition table and boot sector to both say "NTFS", but there is still one thing missing. Apparently Partition Magic claims this missing thing as a "File record signature", but google returns no useful results on this message.

I am going to "get" WinInternals DiskCommander, and see if it can fix the problem. Otherwise, i have R-Studio NTFS, and it says all the files are still there and sitting happily, but i can't recover them because i dont have 80 gigs of space to recover to. I thought of moving 10gigs to my 10GB of free space as another partition, repetitivley until i have all the files on a new partition, but that would involve knowing which files are at the end of the partition in order to not resize the new partition over my files.

2_SeeK_U
9th Sep 2003, 07:20 AM
I have system commander 7 if you want to "test" it.
email me at kdea2@bigpond.net.au

EDIT: ignoor that, l don't think...well l'm not to sure ti would help.

Sounds like your in quite a pickle!! It'll be interesting if you can get it back up!!

Derelan
9th Sep 2003, 03:14 PM
is system commander the bigger brother of Disk Commander? If so, i just found out that disk commander is a useless POS.

So far, the only program thats keeping me with hope is R-Studio NTFS, which shows all my files as safe and intact.

HERES WHAT I NEED: A program to scan the entire harddrive for NTFS files, regardless of missing boot sector/file allocation table/partition table (R-Studio does this). Then, i need that same program to be able to make a partition out of those files. R-Studio can't do that, it can only recover the files, but i dont have anywhere to put them.

2_SeeK_U
10th Sep 2003, 03:20 AM
I think system commmander does all that, you'll have to let me check. I know it does alot though...

Well l'll reply back with the news..

Derelan
10th Sep 2003, 06:14 AM
i found Acronis RecoveryExpert Deluxe, it apparently does what i was describing. Only problem is, it tries to find every single partition that has ever existed on that HD.

So far, i've been scanning for 8 hours, and its 1/3 done. Its found 11 partitions. all FAT16. One of the partitions was deleted on a different harddrive, i just copied files over from that HD and the deleted partition info came with it, a long time ago. Hopefully, if it managed to find 11 partitions in 1/3 of the disk, it will find my NTFS PT.

TheShiningWizard
10th Sep 2003, 07:12 AM
I'll pray for you.

*Goes to bed.*