PDA

View Full Version : Strange lighting phenomenon


Fear the Beard
14th Jun 2003, 07:19 PM
Any ideas why my lighting goes all wonky when I compile the map, see the attached screenshot, the wall is a custom mesh.

[Bean]
14th Jun 2003, 09:57 PM
try reassigning smoothing groups

Radiosity
15th Jun 2003, 06:54 AM
And if that doesn't work, go into the display settings for the mesh and set bStaticLighting to false - there's some epic meshes that go weird with lighting, switching StaticLighting to false fixes it so there's a good chance it'll sort that problem out.

Fear the Beard
15th Jun 2003, 08:46 PM
Well, I'm having no luck at all with this one, if I poke about with the smoothing groups, I get varying results, everything from slightly better to slightly worse.

I've attached a screenie of how it looks with NO smoothing groups.

SoSilencer
16th Jun 2003, 12:04 AM
Static Meshes use vertex lighting. It is quite obvious by looking at the lighting on that mesh that there are very few vertices on that side of the mesh. You can see the individual polygons by how they are lit.

You NEED to use more polygons and you NEED to properly distribute/configure them on the model with the lighting in mind. There are tutorials on this I have seen, though I can't remember where, but this is your problem. Also keep in mind that if a vertex is inside the model or other geometry it will not get lit, thus appearing black, so you need to make sure each vertex is 'reachable' by light.

Fish-MD
18th Jun 2003, 07:41 PM
or u can turn off the lighting on the mesh...tho im not sure u can...turn some edges.
remeber, a shorter edge will look better then a longer edge

if u dont get what that means then too bad, dont have nuff time to explain all that.


ez way to fix that is trying to tessalate the edges in 3ds max or whatever package u use...
select the polygons and press tessalate...make sure u dont **** up tho