PDA

View Full Version : Ahhh!!


bobtheking
17th Feb 2002, 06:31 PM
my editor stopped running!! it is almost done loading, but when it tries to load the texture browser, i get a DDERR_OUTOFVIDEOMEMORY. i've never had a problem before, and the game runs just fine. it just started doing this for no reason, i tried everything, restart, limiting buffers, nothing works! i have a 16 Meg VooDoo3 AGP

Laff
17th Feb 2002, 07:48 PM
reinstall ut ;)

bobtheking
17th Feb 2002, 09:14 PM
i already tried:(

StoneViper
17th Feb 2002, 09:44 PM
reinstall your voodoo software: both drivers and 3dfx tools

bobtheking
17th Feb 2002, 10:48 PM
didn't work

Laff
17th Feb 2002, 11:33 PM
reinstall windows. else buy new comp or take it in to be looked at.

bobtheking
18th Feb 2002, 04:15 PM
wtf, now i get this error:

bobtheking
18th Feb 2002, 04:17 PM
everything else works fine and this just randomly happened. i don't know what caused it, but i've reinstalled voodoo drivers, ut, 436 patch, nothing works!

Bot_40
18th Feb 2002, 04:17 PM
Just after it crashes, open up System\UnrealTournament.log There might be some clues in there.

bobtheking
18th Feb 2002, 04:24 PM
ok, i think i've tracked down the problem, the log said something about my pixeldepthbadformat, or something like that, and my card dosen't support 32bit color. i set my desktop to 16bit and i got it back to the out of video memory error. i think the 3D window is running in direct3D, even though i never set it to that. my editor hates direct3D in the window, but i never get the chance to switch it back. is there a way to mess with the ini and set it back? (even though reinstalling it would set it back, but maybe it defaults or something)

Bot_40
18th Feb 2002, 04:40 PM
Yeah, I just had a quick look at UnrealEd.ini
open it up, you should see that the first things are all the setting for the viewports.
I think just making the Device for all of the 4 viewports to SoftDrv.SoftwareRenderDevice should fix the problem (Am I right in thinking SoftDrv.SoftwareRenderDevice = software mode for EVERYONE no matter what hardware you have?)
Anyways, just make a backup and try it out. If it screws up even more you can just change it back

bobtheking
18th Feb 2002, 06:18 PM
I FIXED IT! it wasn't that the editor was in D3D, but i set the windowed mode to D3D in the unrealtournament.ini file. it was laggy when using the advanced preferences window from the console, so i set it to D3D. i changed it back, and it works! thanks bot_40