PDA

View Full Version : bots controlling a mover?


bobtheking
26th Jan 2002, 08:39 PM
i have this mover in my level, it has four floors to stop at. there are four panels in the floor numbered 1,2,3, and 4. when you stand on one of them, it goes to the floor of your number. it works, but the bots don't use it right. is it possible to get the bots to work with it?

DE.50
26th Jan 2002, 10:32 PM
You said you got the instructions for that overcomplicted mover from someones tutorial, you should try to contact that person.
Or use a different method.

Bot_40
27th Jan 2002, 06:01 AM
I'm assuming it's an elevator mover. Bots cannot use elevator movers. period.

bobtheking
27th Jan 2002, 02:05 PM
what? why?

bobtheking
27th Jan 2002, 06:03 PM
never mind the above post, i got it to work despite bot_40's ignorance, and the bots use it. the trouble now is that for some reason it will work fine until something causes it to shoot down to key 0 and stay there permanantley. triggerPound, triggerControl, and elevatorTriggerGradual are the only states the triggers work, and they all have this problem. what might be causing this?

Laff
28th Jan 2002, 11:10 AM
did YOU call bot_40 ignorant? funny, seems that your mover DOESN'T work like you'd like. =D

and you know thissssss...man!

Bot_40
28th Jan 2002, 12:34 PM
wtf? every time I try to get those bots to use elevator movers the mover gets stuck between keyframes and don't move. Congratulations ;)

TheRealFluffy
28th Jan 2002, 12:58 PM
Setting the mover to Ignore when encroatched, does this help?

Bot_40
28th Jan 2002, 01:50 PM
No, when I've tried them, they work fine without bots in the match. The moment bots are added, they get near the mover and it moves half way between the keyframes and then stops. They don't even get on the mover. They then just run backwards and forwards at the bottom. w3rd :hmm:

bobtheking
28th Jan 2002, 05:09 PM
the main problem with mine is that the bots will run to that little red + to mark the rotation, so they would run on the lift, then run off and run under it after it left. they were trying to reach the red dot, so just put it at the top and it worked. the other thing is that this was a triggered mover, maybe that is the problem?