PDA

View Full Version : Half-Life Problem


Twisted Metal
26th Jan 2002, 01:39 PM
My Half-Life refresh rate is defaulted at 60 hz, which you know causes some visible flicker which is not that annoying when looking straight at the screen however when seen through peripheral vision it becomes really noticable.

Windows is running at an 85 hz refresh rate and I found that the reason Half-Life runs at 60 hz is because it runs in 16 bit color. I know Half-Life could be run in 32 bit color with the -32bpp command in the target box, but that did not fix anything. So, after looking for a solution for the problem on the internet, I found an NVidia refresh rate fix utility which just sets the refresh rate for ALL possible resolutions and ALL possible color depths. So I run it and set everything to 85.

So then I run Half-Life and guess what? It worked. It was running at 85 hz. But guess what else? The framerate got b0rked. It was running at what I estimate to be around 30-40 fps. Now before this refresh rate fix, when Half-Life was running at 60 hz, the frame rate was perfectly smooth, always running at the maximum fps. But now since I raised the refresh rate to 85, the framerate drops. Why is this? How could setting the refresh rate higher make the framerate drop? If anything it should rise. It makes no sense.

VSync is on, because when it is off it causes screen tearing. I did try turning it off, but it had no effect. I tried going back to the original Hercules drivers that came with my card. Same problem. So I reinstalled the newest NVidia ones.

So now I am back to running Half-Life at 60 hz which has a perfect frame rate, but some flicker. My Quake III engine games(Quake III, Medal of Honor, Wolfenstein) run great at 85 hz, but that was set from within the game. Unfortunately, Half-Life has no built in command to change refresh rate. I really don't get it. All the refresh rate fix does is set the refresh rate for all resolutions and color depths. So I set it to 85 and gee wiz my framerate in Half-Life drops. Wonderful. Any ideas?

[BuF]Blorgg
26th Jan 2002, 04:09 PM
Maybe this (http://www.planetquake.com/ztn/nvreffix/nvreffix.html) is what you're looking for, it works for me :)

Twisted Metal
26th Jan 2002, 04:17 PM
No, that's what I used and yeah it worked, but it slowed down my framerate in Half-Life which is my problem.

[BuF]Blorgg
26th Jan 2002, 04:22 PM
Originally posted by Twisted Metal
So, after looking for a solution for the problem on the internet, I found an NVidia refresh rate fix utility which just sets the refresh rate for ALL possible resolutions and ALL possible color depths. So I run it and set everything to 85.


Sorry, didn't read that carefully :/
You're not running in Direct3D are you? If so try: start-->run-->dxdiag-->More Help-->Override and fill in your refreshrate there.

Twisted Metal
26th Jan 2002, 04:27 PM
Nope, OpenGL.