PDA

View Full Version : screenshot


Phloxx
19th Jan 2002, 03:04 PM
I have been having great difficulty screen shotting my level. I took the picture, edited it in paint shop, and tried to import it to the mylevel package. That failed. I later tried importing the same texture into a regular txt file and that worked so I know now that I didn't mess anything up on PSPro. For some ungodly reason, my mylevel package disappeared from the editor and only appears when I open maps from downloads or the original game. Now extemely frustrated, I burned my map to a disc and brought it to a friend. On his comp we were able to import the shot, but when we used it on my map, it still didn't work in the game. Now I don't know what the problem is- my editor or the map itself.

If you actually read all that, I appreciate it. Please send feedback if you have had any similar problems and/or if you know what the problem is.

Chrysaor
19th Jan 2002, 04:15 PM
Is the map 256 colors? Is it explicitly named "screenshot"?

That's all i can think of...You know not to save the MyLevel texture package right? It saves itself with the level.

:MTuk:lone-wolf
21st Jan 2002, 04:49 AM
aye. get your 256 colour photo thing, and make sure its 256x256. Import it into MyLevel (untick generate midmaps, I think). Click the texture/screen pic in the file and go into level properties, go to levelinfo and click screenshot:use.

then rebuild and see if it works in ut.

AMmayhem
21st Jan 2002, 10:48 AM
What they said and make sure it's a .bmp or .pcx

Seco_In_The_Bushes
21st Jan 2002, 07:56 PM
Ok you guys arent seeing the problem. The problem is not the screenshot. Its getting the level to accept it. The level wont except any texture in the screenshot variable. Even a texture from a texture pack. It fills in the slot and stays there but it never appears in ut.

StoneViper
22nd Jan 2002, 12:09 AM
at least you don't have my problem (http://forums.beyondunreal.com/showthread.php?s=&threadid=99655). Sorry, wish i could help.

LXIXGTO
23rd Jan 2002, 06:28 PM
Originally posted by Seco_In_The_Bushes
Ok you guys arent seeing the problem. The problem is not the screenshot. Its getting the level to accept it. The level wont except any texture in the screenshot variable. Even a texture from a texture pack. It fills in the slot and stays there but it never appears in ut.
.
.
Sigh .... I am having the exact same problem Seco.
The map I want to release (Bio Facility) won't
accept the screenshot in the editor.
I have followed the tutorials to the letter but
it just won't accept the screenshot. I bring up the
texture browser after loading the screenshot
and I cannot find it anywhere. :(
.
If you fine a solution to the problem PLEASE let
me know.

:redeemer:




:mad:

Seco_In_The_Bushes
23rd Jan 2002, 07:00 PM
LXIXGTO,

It needs to be a .pcx file.

LXIXGTO
23rd Jan 2002, 07:10 PM
Originally posted by Seco_In_The_Bushes
LXIXGTO,

It needs to be a .pcx file.
.
.
It doesn't make any difference what format the screenshot
is. (PCX, BMP etc...) I still can't find it in the texture
browser. :rolleyes: You have any other ideas?
.
Can't release my first map until I can get the screenshot
to work right. :(
.
Here's the tutorial I am using for reference if you are interested.
http://www.birrabrothers.com/drac/unrealt/ued_tut6dm.asp

:biorifle:




:mad:

Chrysaor
23rd Jan 2002, 09:18 PM
a .bmp takes up more memory in you map. If you make it a PCX it has to 256 colors to work. Bitmaps can be 16mil.

LXIXGTO
23rd Jan 2002, 09:29 PM
That BMP file I submitted earlier was just an example.
Eventhough the tutorial told me to make the screenshot
a BMP I still tried it with a PCX file as well. Still didn't work. :(
.
No matter what I do I cannot find the screenshot in
the texture browser after I have imported it. :(
.
.
This is getting frustrating. :confused:

:biorifle:




:confused:

faderide
23rd Jan 2002, 10:20 PM
Dont know if this will help , but heres how I do it.

1st: get your screenshot from your level f9..know youve done that.
2nd: use paintshop pro to resize it to 256X256. Then reduce
color depth to 256 colors.
3rd: save it to desktop(or whereever) as screenshot.pcx
4th: using texture browser go to file-import-select screenshot.pcx
5th: under package name type :MyLevel
under group-leave empty
under name: screenshot

I tired it with and without the checkmark on generate mipmaps.
This should put your screenshot under your "Mylevel" in the texture browser. Go to it highlight your screenshot, then go to
level properties-level info and under screenshot click the use tab.

LXIXGTO
23rd Jan 2002, 11:05 PM
Thanx Faderide... did all that but it still won't work. :(
.
I imported the screenshot to "MyLevel" but I cannot
open the file with the Tex browser afterwards to put it in the map.
Each and every time I bring up the texture browser to open
the "MyLevel" file after I import the screenshot all I get is
the "Botpack" file. And the texture browser won't bring up the "MyLevel" file at all. :mad:
Furthermore, my screenshot is nowhere to be seen within the
"MyLevel" file when I go and look through Explorer. :rolleyes:
Where is it going when I import it? :confused:
.
I can only find but 2 tutorials on this and I have followed
them to the letter without success. :(
Hate to be shot down by something so simple after I
have come so far. :mad:

:redeemer:




:confused:

LXIXGTO
23rd Jan 2002, 11:40 PM
OK.... I think I got it now ... :D
.
.
The problem I was having was that I didn't uncheck
the "constrain proportions" field when I resized it to
256 x 256 in Photoshop 5. D'OH! :rolleyes:
(it was making image the 256 X 320 by default)
.
After I did that I was able to load my screenshot into
the texture browser. :)
.
However, ... the shot appeared all jumbled after that. It looked
like someone took all the colors and scrambled them.
So... I experimented a little and saved the screenshot as
a BMP file.
Now it works just fine. :D
For some reason it had to be a BMP file not a
PCX file to work. Just as it said to in the tutorial. :hmm:
.
.
Anyway ... Thanx for the suggestions people! :D
(these boards are great!)

:biorifle:




:D